BSOD on Razer Blade 15

Discussion in 'Systems' started by Dzafo666, Aug 5, 2019.

  1. Dzafo666

    Dzafo666 New Member

    Hello everyone,

    in the first place i would like to apologize for my bad english. I need help with my razer blade 15 (i7 8750h, 1070, 16gb ram, 256gb ssd), i receive every time after booting bsod (system_service_exception), can you please help what can be wrong ? Thank you
     

    Attached Files:

    0V3R_K1LL and DRIFT_IT like this.
  2. Joikansai

    Joikansai Well-Known Member VANGUARD

  3. Sonnyoi

    Sonnyoi Active Member

    Use DDU to uninstall gpu drivers and only update GPU drivers via windows settings and see if that helps.
     
    FiszPL likes this.
  4. Mihaiedrisch

    Mihaiedrisch New Member

    I'm bumping all these threads to find out when exactly the Razer Blade 15 Advanced 2018 1070mq will be compatible with the 431.65 release for which the aforementioned model had its support pulled. I've been using 417.71 for almost half a year to prevent BSODs occurring. Very disappointing no Razer staff are addressing this other than on reddit.
     
    Last edited: Sep 2, 2019
    Hermanator likes this.
  5. Joikansai

    Joikansai Well-Known Member VANGUARD

    Answered on main thread, I use 430.86, and I don’t see the need upgrading it since I don’t have BSOD issues. However I’m still on windows 1809, maybe when gears 5 out I’ll update it since it’s required, sometimes windows version and NVIDIA Drivers works like Tom and Jerry.
     
  6. Mihaiedrisch

    Mihaiedrisch New Member

    Are you clarifying that 430.86 is safe for the 2018 Razer Blade Advanced 1070-mq? That it resolved the BSOD problem plaguing many users? Or do you not game or run anything intensive enough and for long enough to trigger it? If it is safe, why hasn't Razer clarified this?
     
    0V3R_K1LL likes this.
  7. figrin1

    figrin1 Active Member

    Did you undervolt your laptop recently? If so, it may be too aggressive.
     
  8. Joikansai

    Joikansai Well-Known Member VANGUARD

    I use Blade 15 only for gaming and intensive workload (see my signature below those are mostly gaming benchmarks), and it’s always on when I’m at home since it’s also my entertainment and media device, for other light tasks like paperwork i use Blade stealth. Trying gpu drivers won’t brick your laptop, so just try it and see if it’s solve your issue. Beside like @figrin1 said too low undervolting, windows version with nvidia driver issue and ram etc may also be the culprit.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >