Core X Chroma USB Problems

Discussion in 'Razer Support' started by Chruschdy, Dec 24, 2020.

Thread Status:
Not open for further replies.
  1. Chruschdy

    Chruschdy New Member

    Hey everyone!

    Has anybody a similiar setup?

    Blade 15 Base (2020) + Core X Chroma and an USB Audio Interface

    I have massive trouble using the audio interface when its connected to the Core X Chroma.

    Many different types of sound errors and recording is not possible because of massive sound artifacts.

    I tried several different settings in the ASIO setup, but nothing helps.

    When the interface is connected to the Blade directly there are no problems at all.
    I tried 2 different audio interfaces but the problem is the same with both.

    I am already in contact with razer support, but they don´t even seem to want to analyze the problem at all.
    The last message i received was an offer to have the Core repaired at some cost (which i purchased only a few weeks ago)

    I upgraded my whole setup to all razer products but by now i am really starting to regret this choice :slightly_sad:

    Maybe somebody else had these kind of problems and found a solution for it. I am relatively sure that there is no hardware defect but the thunderbolt connection in combination with the Cores USB controller is the root of the problem somehow.
    Maybe some other drivers? Who knows...
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >