Cynosa V2 ESC key not working

Discussion in 'Razer Support' started by systemaeroSmokyTopaz940, Aug 12, 2020.

Thread Status:
Not open for further replies.
  1. I just purchased this keyboard a couple of hours ago and everything seemed great. Then I went to press the ESC key to save a game I was playing and nothing is happening. I also tested this with other programs and the results are the same.

    Is this a common issue and is there an easy solution?

    This is on a Windows 10 pc.

    Thank you
     
  2. Jayden257

    Jayden257 New Member

    I had this problem did you try re-starting your laptop/pc?
     
  3. Jayden257

    Jayden257 New Member

    And if its a laptop is it just your keyboard or is it your whole laptop?
     
  4. Its not a laptop, its connected to a pc. Yes I have tried restarting. Also tried the unplug, hold CTRL+Caps Lock+ ESC and plugging back in and it says it installs the device again and requires a restart but I still have the same problem.
     
  5. Another thing to note.I went to keyboard tester.com to make sure the keystrokes are even registering.

    Several of the keys aren't registering at all.

    None of the F1-12 keys seem to be picking up. Also no ESC and the Tilda key isn't working either.
     
    Franticsplash6 and BobbysNuts like this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >