Excessive WMI Provider Host CPU

Discussion in 'Razer Support' started by phoshizzlettv, Apr 15, 2019.

Thread Status:
Not open for further replies.
  1. phoshizzlettv

    phoshizzlettv New Member

    Hey everyone...

    I've been having trouble with my Razer Blade Stealth over the last week with poor audio processing (microphone and output) on several different devices and several different types of media. The symptoms are crackling/delays of microphone input (both USB and onboard jack), and a weird "auto-tune" effect on streaming media like Twitch and YouTube.

    I was able to narrow it down to the WMI Provider Host process being pegged between 20% and 50% CPU constantly. Digging a little deeper, the WMI-Activity log shows several errors every second against processes associated with the Razer Synapse app, or associated processes.

    For now, I've shut down all of the Razer software components, and WMI Provider Host is now idle with very few log entries in the event viewer.

    Curious if anyone else is seeing this and if there are any suggestions on how to deal with it. I am going to try testing this theory across the day, and attempt to stream (where I was having a majority of the issues). I'll post more as I understand the issue better.
     
  2. phoshizzlettv

    phoshizzlettv New Member

    Synapse 3 issue: confirmed. I uninstalled Synapse 3 and have not had any issues with WMI Provider Host consuming 25-50% of my available resources. At some point during the day I'll try to download it again and update to the latest version to see what happens. This is really unfortunate. Not having the RAZER apps to customize and tweak certain aspects of the RAZER experience really saps all the fun and enjoyment out of the products. I'll continue to troubleshoot and hopefully find a happy medium.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >