Fitbit Charge 2 not pairing or syncing

Discussion in 'Razer Support' started by Ella.Bella, Aug 11, 2019.

  1. Ella.Bella

    Ella.Bella New Member

    Hi everyone,

    I've been using my Fitbit Charge 2 with my Razer Phone 2 for about 4 months now without issue until now.

    I followed every instruction I could from other posts about getting a Fitbit to sync so far this is what I have tried.

    - Restarting/Off and On my Razer Phone 2
    - Restarting the Fitbit (including restarting 3 times in a row)
    - Clearing the Fitbit app data and cache
    - Uninstalling the App and reinstalling it
    - Removing the Charge 2 from my Fitbit account/App
    - Removing the Charge 2 in the Bluetooth devices list

    Now when I try to pair my Charge 2 through the Fitbit app it will find the Charge 2 and request a code. The code displays on the Charge 2 but when I enter the code into the App it will just get stuck on 'connecting' with the little wheel spinning. After 5mins or so, the Fitbit app gives up and tells me it was unable to connect.

    This is particularly frustrating as I had no problems with setting up and using my Charge 2 when I bought my phone a while back.

    Does anyone have any ideas that could help?

    Thanks in advance
     
  2. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hi there! Thanks for posting your concern here. You can simultaneously press and hold the Power Button and the Volume Up button for 7-10 seconds and wait for the phone to reboot automatically then pair your Fit Bit 2 and see if it helps. Also, have you tried clearing your Razer Phone 2's Bluetooth paired devices? You can do that turning off your Razer Phone 2's Bluetooth and resetting the Bluetooth on the phone by going to Bluetooth Share and Bluetooth MIDI Service. Try to pair your Fit Bit Charge 2. If in case the issue persists, but your phone can connect to a different Bluetooth device, then there a possible issue with your smartwatch Bluetooth functionality.
     
  3. Ella.Bella

    Ella.Bella New Member


    Hi, thanks for the tips but it turned out that my problem was that my Fitbit Charge 2 wasn't updated and for some reason this prevented my Charge 2 for syncing with my Razer Phone 2.

    In the end I bought a Fitbit sync usb dongle from eBay for £5 and that allowed me to update my Charge 2 from my windows laptop. Now it's working again with my Razer Phone, syncing and doing everything it should.
     
  4. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Awesome! Thanks for keeping me updated. I'm glad that your smartwatch is back in the action again. Feel free to contact me back should you need further assistance.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >