Got a problem with Razer Synapse Software

Discussion in 'Razer Support' started by Forgotten24, Aug 25, 2021.

Thread Status:
Not open for further replies.
  1. Forgotten24

    Forgotten24 New Member

    Hello everyone :)
    I got a new mouse for my iMac, a DeathAdder Elite.
    I downloaded Razer Synapse for macOS but I got the same thing over and over I launch the software: an inscription that reads "Please connect a Razer Synapse enabled device".
    Anyone got the same problem?
    Thank you in advance!
     
  2. Razer.Xenon

    Razer.Xenon Active Member Staff Member

    This is to be expected if you're on macOS 10.15 onwards. While the DeathAdder Elite is supported by Synapse 2 for mac, the app only supports up to version 10.14. Should you have any other concerns, feel free to send me a message.

    *Thread locked to curb the conversation to PMs.
     
    Forgotten24 likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >