Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

HELP - Huntsman Elite

Discussion in 'Keyboards' started by 2PeriodBlood7, May 31, 2020.

Thread Status:
Not open for further replies.
  1. 2PeriodBlood7

    2PeriodBlood7 New Member

    EDIT:

    i dont really speak/write well in english so please bare with me on this one.
    im having problem with my 3 month old keyboard. yesterday, i game for almost 9H + 2H anime watch time after that i put my computer to sleep. When i came back i was surprised that my computer was lit up. at first keyboard was mildly and randomly typing from "windows key, capslock, space, `, c, 1" so i made some troubleshooting it is listed below as follows:

    1. connect-disconnect, restart PC
    2. Reset via synapse
    3. Hard reset > "spacebar + capslock + esc key"
    4. Clean install synapse 4.0
    5. Update keyboard firmware tho i did not record its current version so im not so sure. all i did was update it to the latest.

    having done the basic troubleshooting above all seems well because lights are lit up and its responsive to my keypress however when i type it does nothing.

    i provided a link below for a preview of what im dealing with and see if it helps.
    https://youtu.be/YU7BeADrAHs

    i hope i explain my situation well. TIA
     
    Last edited: May 31, 2020
    Fossilgamer, pancholr and cravenguy like this.
  2. Fossilgamer

    Fossilgamer New Member

    Have you tried to plug in the two USBs into another port, or, if you are you using a usb splitter, plug in both usbs Into a direct port. I would also recommend that if you have not already, make sure you have your keyboard registered to your account so you can secure your warranty and get a replacement. I have the huntsmen elite as well by the way. Good luck and I hope you have a great day.
     
    pancholr and cravenguy like this.
  3. 2PeriodBlood7

    2PeriodBlood7 New Member

    im plugging it directly on motherboards 2.0 USB port, already registered it to my razer account the day i bought it. man this is getting frustrating my ticket hasn't been answered. reddit CustAdv seems very tired of reading and doesnt even get the point of my message. to top of that i can't contact my seller of my keyboard. :/
     
    Fossilgamer likes this.
  4. freshMiddleBlue410

    freshMiddleBlue410 New Member

    Can you use the on-screen keyboard so you can see the keys as you press it? That would tell you if the computer sees your keyboard. Also try using the FN and Menu keys to see if you can cycle to a useable profile.
     
    Fossilgamer likes this.
  5. Fossilgamer

    Fossilgamer New Member

    If you use the razer synapse software it will show which keys are registering while in studio. I think the problem may (I am not 100% sure) lie in the fact you are using usb 2.0 as opposed to the current usb 3.0.
    As said by freshmiddleblue410 you could press the FN key and see if the press able keys light up. If you have still not found your answer you can contact moderators directly on Facebook, Twitter, and on Insider. They are very punctual in answering from my experience.
     
  6. 2PeriodBlood7

    2PeriodBlood7 New Member

    the thing is you can't use the keyboard once the problem starts. see clip here https://youtu.be/zCMSUrSRT_c , i also tried using different profiles, to no avail that doesnt fix either, tried esc+capslock+space seems to fix the problem but on a temporary basis. just like shown in the clip i was just watching when the problem suddenly persist.
     
  7. 2PeriodBlood7

    2PeriodBlood7 New Member

    to avoid further repetition on replies, please read reply #6 about the profile switch. they already updated my case and it is subject for RMAing even my dealer already replied and they say they will subject it for warranty.
     
    DRIFT_IT likes this.
  8. Fossilgamer

    Fossilgamer New Member

    Great, I hope you have a great day.
     
    2PeriodBlood7 likes this.
  9. 2PeriodBlood7

    2PeriodBlood7 New Member

    Replacement arrived yesterday. but i had to sacrifice my original keyboard in order for them to send a new one. transaction took about 1 month with continuous follow-up :)
     
    Fossilgamer and shmekermeister like this.
  10. Fossilgamer

    Fossilgamer New Member

    That's great, I hope you enjoy it.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >