Help Please? - Razer Ripsaw HD "No Active Signal"

Discussion in 'Razer Support' started by nyieon, May 5, 2021.

Thread Status:
Not open for further replies.
  1. nyieon

    nyieon New Member

    Hi everyone!

    I just bought a Razer Ripsaw HD to stream my PS4 to my PC but I get a message saying "No Active Signal" and there is just a black screen if I try to open it on Streamlabs OBS/OBS (I tried both).

    - The computer recognizes the device and I do have USB 3.1, so it's not the USB right?
    - On my PS4 I have already disabled HDCP and I can see the PS4 screen on my TV after plugging it through the device so it's not the HDMI setup?

    Is my capture card just broken/defect? Could it be something else wrong?
    I really don't want to have to return it, ugh :frown_::frown_:
     
  2. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey there! Thanks for making this thread. Please go to your PS4's home screen and click the settings. Then go to the system and uncheck the Enable HDCP. It's also possible that your HDMI cable has a problem. If the issue persists, send me the serial number of your Ripsaw via PM. Let's continue our conversation from there.
     
  3. rwilli4982

    rwilli4982 New Member

    Is there a way for you to help me as well I have been tryihng to fix this for 5 weeks and I am getting no where with support
     
  4. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Sorry to hear about your ongoing issue with the Razer Ripsaw HD. Have you tried reaching out to our Support Team submitted by a case too? If you haven't, please click here or send me a PM so I can assist you. I'll be locking this thread now.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >