Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

HELP Razer Naga Trinity left & right buttons acting up

Discussion in 'Razer Support' started by Arkinian, Mar 17, 2020.

Thread Status:
Not open for further replies.
  1. Arkinian

    Arkinian New Member

    I have had this mouse for a few months, it recently started acting up. When I hold down either mouse button to highlight text or to drag icons it acts like I'm letting go of the button or pressing it over and over again.
    It does this when I'm trying to move shortcuts on my desktop,or moving files in explorer too, accidentally double clicking icons when I am trying to organize or opening a txt file into an exe.

    I first thought it was a recent windows update so i did a system restore before the last update with no change. I uninstalled and reinstalled the drivers. I let my son use it on his PC with no problems playing minecraft or battlefield. I have tried different USB ports on my pc and even added a usb hub with no success. Frustrated I reformatted my SSD and did a fresh install of windows 10. it still is messed up!

    I hooked up an old Logitch USB wireless mouse and it works flawlessly. I don't know what to do now.
     
    ForrestWolve likes this.
  2. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Does this happen with all side panels? To be honest, this sounds like a switch issue. Do you do any form of drag clicking?
     
  3. Kal25

    Kal25 New Member

    Hey. I'm having the same issues with my Trinity. While hold dragging with my mouse it occasionally drops out with the hold as though I let go of the button for a fraction and then held it again.

    Strange thing is I tried my old Naga (2014) and the same thing happened. I plugged both into a different computer and they worked fine.

    From my (very) limited knowledge sounds like it's a software issue but I've uninstalled the devices and checked for driver updates and it all seems fine.

    Currently using both Synapse 2 and 3. Both are up to date.
     
  4. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    @Kal25

    We could try a clean installation of both the app the drivers. Shoot me a PM with the serial number of your mice so I can check for firmware solutions.
     
  5. I have the issue with a brand new Naga Trinity.
    Unable to drag with the left mouse.
    If I assign LMB to a different button the side, I can use that to drag, but it's super annoying.
     
  6. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Do you get the same results with and without Synapse running in the background? Things may get a bit tricky since we don't have any firmware that targets this.
     
  7. ForrestWolve

    ForrestWolve New Member

    Same here to me. Brand new Naga Trinity, Left click does sometimes 3 Clicks at once and cant drag really clean. is there any fix right now ? do we have a chance to get this clean ?
     
  8. Synapse is not running, the issue persists...
    My other mice never had this issue.
    I also tried different USB Ports, same issue.
    Same issue on another machine, without any Synapse installed.
    Had I figured out there was a problem sooner, I would have returned it.

    It's just over 1 month old.
     
  9. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    @ForrestWolve Please PM me the serial number of your mouse so we can try to troubleshoot and further isolate the issue.

    @dailyVividAuburnheat598 I believe you've done all the recommended troubleshooting already. There nothing left to do but have it replaced. Please PM me the SN of your device so I can help you with the RMA.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >