Huntsman Mini. Key stuck from day 1.

Discussion in 'Razer Support' started by ChillyRide, Jul 9, 2022.

Thread Status:
Not open for further replies.
  1. ChillyRide

    ChillyRide New Member

    I am very curious why people dont complain about this issue. So I am on AMD system and from day 1 it was nightmare with this keyboard. Razer fixed some issues but not all.
    Lets go to the topic. No matter what game I play when pressing couple buttons at once my key are stucked. Usually its WASD. Character moves while I dont press any keys. Pressing any key will resolve this issue. Kinda fantom keypress. It was from day 1 and persist now. My guess its firmware problem. Cause with razer synapse and drivers installed and without synapse and drivers keyboard behaves the same.

    AMD system, latest bios. No issues with other keyboard. Tried different usb ports on mobo, still the same problem. Kinda tired of this problem have not been resolved for such long time.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >