Hypershift not working, Huntsman Elite

Discussion in 'Razer Support' started by YorickSK, Dec 22, 2020.

Thread Status:
Not open for further replies.
  1. YorickSK

    YorickSK New Member

    Since a couple of days ago my Hypershift seems to have stopped working properly.
    Whenever I press my Hypershift key (fn) all the lights on the keyboard turn off except for a couple highlighted ones like usual but it acts just as if the button isn't pressed.
    I've tried resetting the keyboard and recreating everything on a different profile.
    I have also tried binding the Hypershift function to a different key, but it shows the same results.

    My Windows 10 and Razer Synapse are both updated.

    Hope someone can help me with this!
     
    DerTyp7214 likes this.
  2. oktronic

    oktronic New Member

    Hi, I have the same problem. I got a update for synapse a few days ago, and the hypershift buttons stopped working. I can't use the keyboard to put the computer to sleep.

    Could use some help please!

    Thanks
     
  3. adingess

    adingess New Member

    Same. December update KILLED Hypershift for my huntsman elite. Do you guys not test your updates before pushing them out?!?
     
  4. oktronic

    oktronic New Member

    A little more info. I've found that if I reboot, the button will work once. I can put it to sleep, but after I come back it doesn't work. I also shutdown the Razer Synapse Service, and the buttons would start working again, except you lose the chroma colors, etc.
     
  5. WannaJuice

    WannaJuice New Member

    Hi,
    I posted this issue on reddit and somebody said that the cause of hypreshift issues is wrist rest. Now if I have wrist rest attached to keyboard the hypreshift sometimes works sometimes it dosn't. When wrist rest is unattached from keyboard the hypershift works! He also mentioned december update to breake this. This is my first razer keyboard which I got as christmas present and I thought that I got a broken one because I couldn't know that it was ok before december update!
    Here is link to reddit post:
    https://www.reddit.com/r/razer/comments/kkt77r/hypershit_doesnt_work_on_brand_new_razer_huntsman/

    The razer support wanted me to return my keyboard to send me new one but i live in a country where they don't even ship :D If I sent my keyboard somewhere It would be lost forever :D.
     
    everVividTangerine709 likes this.
  6. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey everyone! Thanks for initiating this thread. Please collect the Synapse 3.0 logs, and let our Support Team look at the logs by submitting a case, Ensure to save the compress files via Google Drive or to any online drive account, then paste the link in the message field.
     
  7. adingess

    adingess New Member

    This was done almost 2 weeks ago and there has been zero attempts to fix this since. Please explain why people should spend $200 on your keyboards if they don't work AND you DON'T provide support in a timely manner???

    On a side note, Is anyone else getting random website errors when trying to post a reply? It never says what error has been called, and I have to click "Post Reply" about 7-10 times before it actually posts a reply???
     
  8. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Thanks for letting me know, @adingess. Do you have a case number on hand?


    Has everyone submitted a case to our Support Team? If you did, please send me a PM together with your device's serial number. Let's continue from there. I'll be locking this thread now.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >