Issue with forum profile

Discussion in 'General Discussion' started by Cobragod, Mar 1, 2019.

Thread Status:
Not open for further replies.
  1. Cobragod

    Cobragod New Member

    Hi guys,

    I'm a newbie around here and I have some issues with my profile.
    I updated my avatar, but for some reason it doesn't display as such on the forum. Any idea why?
    Also, I completed some actions that should have rewarded me trophies, but they still show as incomplete on the rewards page. Does anyone have suggestions on how to fix that?
    Thanks a lot for your help.
     
    pancholr likes this.
  2. Kenserky

    Kenserky Well-Known Member

    Hi,

    Seems that your avatar has been updated, you might have waited for an admin aproval.
    Wich rewards are your talking about ? if it's somes like link twitter and facebook acount they don't work since a long time.
    That's why they said that the rewards panel will get a refresh.
    https://insider.razer.com/index.php?threads/insider-house-cleaning.46171/
     
  3. Cobragod

    Cobragod New Member

    It wasn't about facebook or twitter. I was referring to things like posting something or giving a like, which I had done but were appearing as not completed, for some reason.
    Now I see they are. No idea what happened, but as long as it's fixed, it's all good. :smile_:
    Thanks a lot for taking the time to reply.
     
  4. Kenserky

    Kenserky Well-Known Member

    You're very welcome.

    All those trouble may have been from you new account on Insider, things can take some time to valid it.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >