Issue with Synapse 3. Games do not appear to link to profiles. Cannot add EXEs manually either

Discussion in 'Razer Support' started by x86_x64, Jun 2, 2021.

Thread Status:
Not open for further replies.
  1. x86_x64

    x86_x64 New Member

    Synapse 3 version 3.6.515.51215.

    I've been trying to add my games to the Profile -> Linked Games section so I can link them to a profile for my Razer Tartarus Pro but the scan never lists any games. If I try to add an EXE manually, the program freezes for about 10 seconds and then returns with the game still not in the list.

    I have attempted a full uninstall and removal of Razer folders in Program Files, ProgramData, and appdata/local then a fresh reinstall after multiple reboots. This did not change the behavior.

    I have a large steam library (over 500 games) plus games from other services. Razer Cortex has no problem showing all my games but I cannot get Synapse to see them.

    Windows 10 Version 20H2 OS build 19042.985

    Any help is appreciated. I did search around and see the posts about removing specific files in the ProgramData folder, I tried those out as well and they didn't help.
     
  2. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    When did the issue start? Were there any changes applied to your system or Razer Synapse like an update perhaps? Let's repair your Razer Synapse and check if the issue persists. Please click this link. Feel free to send me a PM should you need additional assistance.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >