Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Just bought nari ultimate. has echo that I can not get to stop.

Discussion in 'Razer Support' started by everVividYellowalley418, Nov 16, 2019.

Thread Status:
Not open for further replies.
  1. I just bought these headphones, and everything worked fine until I discorded a buddy to play a game. From the very beginning, he said there was echo. He could hear himself and my computers audio.

    I have tried every single solution online I could find. Discords echo cancellation doesn't work. Nor does changing any sound options, or quality. The only thing that does make it stop is disabling the mic itself in the sound settings. Other than that, it is this excessive echo that won't go away and is driving me nuts at this point. Every pair of expensive headphones I buy always has some issue.

    No idea what to do at this point. I'm really hoping someone has a solution. Or at least news on a software update coming in the works. AS it seems others have this same issue to.
     
  2. muting the mic also makes it stop
     
  3. I can't get the things to update either. It's telling me to plug it in, which it obviously is. And the device manager brings it up as a usb device, the headphones themselves. Everything is refusing to work with these.
     
  4. Damon-USA-

    Damon-USA- New Member

    I had the same issue, but a friend told me to look at the following. And it fixed it instantly.

    Path: Windows Sounds> Recording tab> select the Headset Microphone (Razer Nari Ultimate - Chat)> Properties> Listen tab> ensure the checkbox for Listen to this device is unchecked> ALSO ensure the Playback through this device is set to Speakers (THX Spatial - Synapse)
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >