LMB stop working every couple minutes (brand new Deathadder Essential)

Discussion in 'Razer Support' started by miwoj, Feb 5, 2020.

Thread Status:
Not open for further replies.
  1. miwoj

    miwoj New Member

    Razer Deathadder Essential: Left Mouse Button randomly stops working every couple minutes

    I can still move a cursor but LMB does nothing.

    Weird part: clicking RMB fixes the problem, LMB starts working again for some time until it happens again

    I've tried:
    • Doing a clean reinstall of everything: drivers, synapse, reset settings etc.
    • I have only Central and Synapse 3 installed (and updated), no other modules.
    • Using different USB ports
    • Haven't changed any razor factory setting, no custom profiles, no macros, everything is on default.
    • All my drivers are up to date, windows is up to date, all my apps are up to date etc, my system is perfectly maintained and flawless.
    I can't tell if the mouse is broken and i should get it replaced, or if it's a software problem that can be fixed.

    Update:
    I just noticed something. Even though i can't click LMB on anything, i still can drag and resize some windows, move scrollbars etc.
    but only some windows, other still completely ignore LMB. i have no idea how that works.
     
    Last edited: Feb 5, 2020
  2. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    You've pretty much done most of the troubleshooting. The only thing left is to check for firmware updates. Please PM me the serial number of your mouse so I can do just that.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >