Nari Ultimate THX Mixer won't see applications.

Discussion in 'Razer Support' started by Stormogedion, Jul 17, 2020.

Thread Status:
Not open for further replies.
  1. Stormogedion

    Stormogedion New Member

    The THX mixer shows my apps, but they're all greyed out. I've tried restarting before and after starting the applications I want. They normally should be colored and at the top of the list, but I cant get them to show up, Any help would be appreciated, thanks.
     
    skullhardcore likes this.
  2. Drummah

    Drummah New Member

    This happens on and off for me too. Some days the apps are lit up showing it's recognizing them, other days it's not. This app is very hit or miss. I've done numerous fresh installs and deleted all razer folders each time. Why doesn't this software work as intended? I'm seeing many people having the same issues.
     
  3. Eons520

    Eons520 New Member

    I also constantly have this problem. The headset is great all around and works well (except maybe the microphone quality) but the software really hinders the capabilities. The THX spatial audio will randomly grey out all my applications and ask me to set it as my default device, but it already is the default device. I have to then reinstall synapse for it to work properly. Honestly, the hassle is not worth the money...
     
  4. Drummah

    Drummah New Member

    Even after the recent update, Synapse 3 still stops recognizing apps. I notice it happens sometimes, not all the time upon exiting an app. Sometimes I quit a game and it will recognize the next game I open, other times I quit a game and it greys everything out and bass boost stops working. The only solution is to restart my system. It's not the hardware, it's clearly the synapse 3 app.

    Where is the quality control? I've reinstalled it (cleanly), as well as the drivers probably 6 times since purchasing Kraken Ultimate a month ago, which temporarily fixes the problem, but it always comes back. This is sickening, and look, how many posts in their SUPPORT FORUM, and not one representative response. This is a common problem with Synapse 3 and I'm losing any faith I may have had in this company after being a customer since 2014.

    When someone does respond, all you hear is the same troubleshooting advice over and over. "Uninstall synapse, uninstall the drivers, restart your pc, reinstall synapse 3." We've done this already a dozen times, patch your software. The problem is clearly on the end of their software team and the app clearly does not get along with Windows 10 consistently.
     
    DejanGaz likes this.
  5. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey everyone! Thanks for posting your headset's concern here. Allow me to move you move things along. By the way, were you able to contact our Support Team via phone, chat, or email? If you haven't please submit a case here or send me a PM together with your device serial number or case number. Let's continue from there.
     
  6. 11punisher11

    11punisher11 New Member

    i have the same problem if i uninstall the program and reinstall it it will work until i restart my pc and it stops activating my programs and games help please. i cant just uninstall it and reinstall it all the time its not worth all the hassle.
     
  7. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hi there! Please send me a PM together with your Razer Synapse 3.0 logs. Save the compressed file via Google Drive or to any online drive accounts. Let's continue from there.
     
  8. Meisner57

    Meisner57 New Member

    ive got a standard nari and have a similar issue... for me my apps won't show up in the list at all!
     
  9. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Have you tried connecting the headset to a different computer with Razer Synapse 3.0 installed? Should the issue persists, please send me a PM. Let's continue from there.
     
  10. Hi, I have the exact same issue on my main machine... I was able to select applications just once, all the rest is greyed out. I reinstalled and performed a clean installation about 15 times, issue still occurs... Please help, this is definitely not worth the money, i just bought one of your blackshark V2 and the main feature of it which is the thx spatial audio cannot be used......
     

    Attached Files:

  11. I did in my case and it seems to be working but this is not the computer i use to play
     
  12. Meisner57

    Meisner57 New Member

    Good luck... I have been going back and forward with support for weeks and finally today they have given up. Response I got basically said it's something else causing it and it's not there problem, maybe try reinstalling windows, good bye.
    Pretty annoyed, but I guess what can I do other than suck it up I try to enjoy my device without a key feature.
    Hope you have better luck
     
  13. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Thanks for letting me know. Please send me photo's of the following:

    upload_2020-12-7_15-49-51.png
    d. Synapse 3.0 logs

    Save the files via Google Drive or to any online drive and paste the link in your PM. I'll wait for your follow-up.
     
  14. Do you mean from the pc it seems to be working fine or the one on which it is not working?
     
  15. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hi there! If you can send both, that would be awesome. Ensure to separate and rename the folder of the logs. I'll wait for your follow-up via PM.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >