[NEED HELP] Razer Blade 2015 Bios modification

Discussion in 'Systems' started by miikarei, Apr 6, 2019.

Thread Status:
Not open for further replies.
  1. miikarei

    miikarei New Member

    Hello there

    For 4 years I've the same Razer Blade (with GTx960) + Core GTX1060.
    And since the beginning, when I turn off my laptop, the Core Blow link a tempest and never stop.
    I have to remove the Thunderbold cable from the laptop, to stop the Core blowing.

    And today I was thinking, inside the bios, I can choose to desactivate USB when system is off.
    That's what I did

    and now nothing works; Core won't connect, keyboard of the blade won't work too;
    until the windows screen comes.
    But I just want to access to the bios to reactivate the USB.

    Anybody can help me ?
    thanks a lot
     
  2. kamueone

    kamueone New Member


    Just press shift while rebooting. This will bring you to a menue in which you can choose to boot to the bios.
     
  3. Joikansai

    Joikansai Well-Known Member VANGUARD

    I’m a bit confused, Blade 2015 14 and pro doesn’t have TB3 how can you connect it with the core. Did you mean Blade 2016 with Gtx 970m? Did you flash the bios to change it or only from default bios option through pressing esc button after boot? If the first you can reflash the original, don’t say you don’t have it. If second, you can access optio bios menu I think old Blade is also same by pressing esc or f1, and reactive it again.
     
  4. miikarei

    miikarei New Member

    Tried it and won't work :slightly_sad:

    sorry I forgot the CGU I had inside; this is the Blade with 970m inside.
    I think I flashed the bios;
    when I boot the laptop, black screen, lower right, mention "bios A0"

    and upper left:
    press DEL / F1 to menu
    F9 to recover
    F12 to boot

    but here, keypad don't work so impossible to access to the option bios menu
     
  5. Joikansai

    Joikansai Well-Known Member VANGUARD

    Try external keyboard if it doesn’t work try resetting cmos battery to reset bios.
     
  6. miikarei

    miikarei New Member

    hello there

    I tried an external keyboard but same problem, it's USB keyboard; so... it won't work

    I Teardown the computer and reseted the cmos battery.
    After I was able to came into the bios.

    thanks for the tip!!


    but maybe you know how to do, when I turn off the computer, the core doesn't blow like a reactor?
    Is there an option somewhere to disable Thunderbolt power when the computer is off?
    thanks
     
  7. Joikansai

    Joikansai Well-Known Member VANGUARD

    I saw this issue on stealth 2016 and core v1. Do you use Razer gpu switcher? I use that with core v2 since Blade 14, around 3 years I had only once that problem but solved idk how forgot, but it was on first installation new gpu. Maybe try using different drivers that compatible with both cards, 970m and 1060. GPU on Razer Core will kick on high rpm until it detect the vga connection on the system, basically when turning off it should also automatically shutdown. If it’s still existing try also contact support maybe they know the solution from previous cases, not by RMA but by software.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >