No sound when using THX sound option after latest update

Discussion in 'Audio' started by girkers, Jan 21, 2022.

  1. girkers

    girkers New Member

    I have a Nari Ultimate and as a diligent user when Razer says I have a software update for Synapse I go ahead and do it. However now many of my audio options have changed and no matter what I do I can no longer get audio out when I choose the THX option.

    These are the new sound options I have:
    upload_2022-1-22_14-38-39.png

    As you can see I have "Headphones (THX Spatial Audio), but when that is selected alas there is no sound.

    Before the update my THX was working fine I had the option Speakers (THX Spatial - Synapse) and things were fine.

    In Synapse itself:
    upload_2022-1-22_14-52-14.png

    When I press on the "Set as Default" it does nothing and again even if I set it manually the Calibration is not heard.

    Any ideas how I get my THX to work again?
     
    pancholr and Floftw like this.
  2. Floftw

    Floftw Member

    I have exactly the same issue.
    I don't know why Synapse is still so broken.
     
    pancholr and girkers like this.
  3. girkers

    girkers New Member

    It is good to know that someone shares my pain, hopefully someone can help us soon.
     
    pancholr likes this.
  4. Pumba696

    Pumba696 New Member

    It is kinda reassuring that im not alone here haha I have a Kraken Tournament Edition and cant get any sound when selecting the Speakers (THX Spatial- Synapse). Really disappointing, If they dont fix it soon ill probs go and buy something else :slightly_sad:
     
    pancholr likes this.
  5. Dino89

    Dino89 New Member

    I had this issue with new kraken v3 pro, switching between audio outputs and pausing audio like playing music for a while resulted in no more audio going from THX audio device. Found out that is definitely bug within the synapse as if you close it, audio wil work suddenly at least this was in my case.

    Sadly in the end i had to return my v3 pro in the end due to many other issues hw and battery related.
     
    pancholr likes this.
  6. girkers

    girkers New Member

    I have been working with support going through there step by steps, with nothing working, I feel part of the issue was they didn't quite grasp what my issue was.

    Any way I have been finally able to get sound out to my Headphones with the THX sound device. In the end what worked for me was:
    1. Go into Device Manager;
    2. Expand Sound, video and game controllers;
    3. Right click on THX Spatial ( I think from memory it had word "Audio" in it too and select "Uninstall Device";
    4. I selected to "Delete the driver software for this device", you can also try without first time and see how you go, I just jumped straight in;
    5. Reboot computer;
    6. Follow the below linked instructions, but when you get to step 9 for me there was no "Razer" option, however I did have a THX option:
      1. upload_2022-1-28_13-45-35.png
      2. https://mysupport.razer.com/app/ans.../AvO4cQqNDv8Q~WiOGs4e~yL3JoEq1C75Mv_U~zj~PP9d
    7. Click Next, Next;
    8. After installing the driver I then had my old sound option back:
      1. upload_2022-1-28_13-47-1.png
      2. And it was working fine
    9. Reboot computer and I found that it was all good working with Synapse software.
    In my reply to support I have asked for a review of why this issue happened and how to avoid it happening again on the next update. I will report back when/if I get a reply.

    Please let us know if this works for you so that others may benefit from your experience.
     
  7. cemsengul

    cemsengul New Member

    I have issues with the THX Spatial Audio app after the last Synapse update as well. My issue is different though. I still have sound on my laptop but I can no longer use the presets in the THX app.
     
  8. Dino89

    Dino89 New Member

    Tried this fix, however is did not solve anything. For V3 PRO and its THX driver there is still audio "leakage" and device itself does not work at all. I dont know what happened but synapse in terms of audio is going down hard. Which is sad
     
  9. girkers

    girkers New Member

    Sorry to hear that this didn't work for you folks.

    I did get a reply back from "Alson" who said "we have ping this issue to the higher relevant team for them to review", I just hope they are genuine in their intentions.
     
  10. cemsengul

    cemsengul New Member

    I have been live chatting back and forth with Razer about this issue for a few days. I think I might have helped speed up things.
     
  11. EthanS3000

    EthanS3000 New Member

    Not sure if this is the same issue that you guys are referring to, but I have noticed a problem in Windows 11 very recently. I own the Blacksharck v2 headset. I set audio "Speakers (THX Spatial Audio)" and the headset works fine. When I unplug the USB Razer soundcard then I get no sound out my speakers. I have Realtek audio on my motherboard. I never had this problem before. I would select "Speakers (Realtek USB audio)" as my fallback device in Synapse as usual. What I noticed under the windows control pan, Sound is that when the headset is plugged in I would see the green audio levels meter work for both "Speakers THX Spatial Audio" and "Speakers Razer USB Sound Card" and I get audio out of the headset. When I unplug the USB I would get the green audio levels meter under "Speaker THX Spatial Audio" and "Realtek Digital Output". This is not correct. I had to "disable" Realtek Digital Output and now when unplugged the Speaker THX Spatial Audio and Speakers Realtek USB audio have the green audio levels and my speakers get sound again! I don't know if this was a Windows update or update of the Razer software that borked this.
     
  12. petters.uk

    petters.uk New Member

    They are absolutely takin the bloody piss... so many issues, and now no audio thru thx...
    straight away return and going back to different product... it's like they just wanna loose customers :)

    @girkers Thank you, it worked thanks to you...
    ps: Buying razer was the worst mistake, i'll be sure my next product from razer gonna be in return :)
     
    Last edited: Feb 1, 2022
  13. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hi girkers and cemsengul! Please send me your case number via PM, so I can review your contact history.

    That's odd, EthanS3000. Did you try running the Windows Sound Troubleshooter while experiencing the issue?

    Your feedback is well-taken, petters.uk. Razer is aware of this behavior, the main reason the team published the workaround from this link.

    Hi Floftw and Pumba696. This shared article posted by girkers should be able to help you with this audio device concern, which can also be seen from this thread. Feel free to submit a case to our Support Team or send me a PM so I can kick start an investigation on your behalf.
     
  14. petters.uk

    petters.uk New Member

    Good and thanks.
    Now pass this forward, Razer sells products for competitive gaming, so because of this audio issue, that is absolutely unacceptable, I got kb and mouse from ss, and guess what, no issues… so automatically Razer just lost 400£ worth of competitive gaming product sale… now razer answer may be “who give’s a damn?” but as this type of issues aren’t solved, it will be followed by many customers to change orientation, especially when you buy competitive gaming products without looking at the price, because the reals customers don’t look at the price, just at the quality delivered.
     
  15. cemsengul

    cemsengul New Member

    I don't understand why Razer has not fixed this issue yet. Almost every Razer owner has lost the function of the THX Spatial Audio App after some Synapse update. We did not purchase these computers to not enjoy THX.
     
  16. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    I appreciate your comment. The team is currently watching this thread. And yes, I've forwarded your post to our Internal Team.

    Everyone deserves to use a fully functional device and software. However, technology roadblocks (bugs) happen. There could be an external or internal source affecting the software's behavior. I'm working with our Support Team by encouraging everyone from this thread to submit a case and share their MSinfo and Synapse logs, which are essential during the investigation.
     
    FiszPL likes this.
  17. cemsengul

    cemsengul New Member

    Maybe Razer can get around to finally uploading the 2021 Razer Blade Advanced drivers on their website and we can try to uninstall the THX Driver that is 363 MB and reinstall it? Why do we not have access to drivers but people with older Razer laptops can download their drivers?
     
  18. girkers

    girkers New Member

    Sent you a PM as requested.
     
  19. Hi thanks i have the same issue.
    I tried your method but it did not work.
    Thx synapse is not avaiable.
    I am trying to reinstall synapse.

    I hope razer will fix that ASAP.
     
  20. I succeded to bring back the drivers by reinstalling synapse
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >