Noticeable light bleed on start up - Blade 15 2018

Discussion in 'Razer Support' started by polyline, May 5, 2019.

Thread Status:
Not open for further replies.
  1. polyline

    polyline New Member

    Hi everyone! First time poster here... So I have been looking at getting a new laptop for about 2 years now, and after looking at every alternative, I just couldn't resist getting a Razer Blade 15. I recently bought the 2018 1070 144hz model from Microsoft Australia's ebay store, as the prices were heavily reduced. Arrived within a few days and I was nervous to turn it on due to hearing about light bleed issues. This is what I saw upon starting it up, and was a little disappointed. Thoughts?

    I tried my best to get a realistic photo with my phone, without overexposing it. The bottom left corner is the brightest and most distracting. I haven't used it enough to know how much it will bother me in normal use.
     

    Attached Files:

  2. Razer.FatKidWanderer

    Razer.FatKidWanderer Well-Known Member

    Hi there, @polyline! That seems not right. Have you tried to reach out to your reseller to have this replaced? We suggest doing it so they can have the unit replaced right away. Send us a PM if they are unable to do so.
     
  3. polyline

    polyline New Member

    Thanks for the reply. I was debating whether it warranted getting a replacement as everything else seems fine with it. I am also a bit stuck at the moment as I need to use the laptop for a work experience placement for the next few weeks so I can't afford to send it back right now... I will probably just have to live with it.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >