Oculus Link with Razer Blade Advanced

Discussion in 'Systems' started by DaiBach99, Aug 6, 2020.

Thread Status:
Not open for further replies.
  1. DaiBach99

    DaiBach99 New Member

    I have a Razer Blade Advanced (mid 2019), and recently purchased an Oculus Quest VR headset. I forked out £80 for the official Oculus link cable, but it runs like a dog through the thunderbolt port, frame rate in single figures.

    I read somewhere that the Thunderbolt port does not pass the nVidia graphics card so you end up using the on-board Intel graphics. That sucks. Is this true?

    Is there a way to get the Razer Blade to work adequately with Oculus Link? Would a standard USB-A to USB-C cable work or does that also suffer from the same issue with connecting only Intel graphics?

    I am using Virtual Desktop app which works quite well over WiFi but would like the throughput that the USB 3 cable should bring.

    Thanks!
     
    pancholr likes this.
  2. Brastic

    Brastic Active Member

    I cannot imagine a USB-A port working for VR graphics. I use one at work for a 3rd monitor, but I do programming, so that is just some text on a screen and is fine. I have the Oculus Rift S working from my 2017 Pro laptop. I had to find a very good Thurderbold to Display port adapter. I want to upgrade to a Blade Advanced next year so I am going to watch what you do here. Good luck.
     
    pancholr likes this.
  3. Joikansai

    Joikansai Well-Known Member VANGUARD

    Yes usb C isn’t directly connected to nvidia gpu, on Blade 15 2019 (there’s two models), I heard only DP on some model connected directly to nvidia gpu unlinke 2018 which the HDMI is also connected to nvidia gpu. On 2020 15 however there’s new usb c port on left side that connected directly to nvidia gpu. Not sure how it works with VR headset since I’m not specified on this setting. Maybe for signal you need connection to DP and powering you can use usb A, not quite sure though.
     
  4. DaiBach99

    DaiBach99 New Member

    Well more money wasted on cables, I bought a USB-A to USB-C cable as the Thunderbolt port was not an option, it linked at high speed 1.6 Gbps and I was hopeful games would run acceptably but no - must be the same issue as the Thunderbolt; although it is high speed, again the nVidia GPU is not connected so this was even worse, SteamVR crashing most of the time, or on the rare occasions it worked, frame rates were again completely unusable. Minecraft VR worked reasonably well though, I guess it can run on the Intel integrated graphics chip just about.

    My assumpion is the Razer Blade Advanced is not capable of Oculus Link operation as Razer borked the Thunderbolt/USB interfaces to prevent the graphics to pass. I wish I'd known this before forking out >£100 on cables, I searched for an architecture diagram for the Blade Advanced showing what is connected but could not find anything.

    All is not lost however, there is an app called Virtual Desktop in the Oculus store (it's not free, about £15 if I recall) that actually allows SteamVR to work untethered over WiFi. What's more as it is simply streaming the graphics from your laptop you can use the internal nVidia GPU or an eGPU. Performance is decent providing your WiFi is fast enough. You don't however get to use any Oculus Link apps you have downloaded as the app does not see your headset connected. You can run Minecraft in VR with this setup but you have to install the java version on your PC and tweak things a bit with a download called Vivecraft.

    Summary - if you have Razer Blade Advanced, don't waste your money on cables for Oculus Link - it simply will not work. Consider using Virtual Desktop if you want to run SteamVR games, it won't be as fast as USB3 speeds but it's reasonably good.
     
  5. TheParadyme

    TheParadyme New Member

    From personal experience of using Oculus Link on RBP (2020) as well as technical curiosity to answer your questions:

    "I read somewhere that the Thunderbolt port does not pass the nVidia graphics card so you end up using the on-board Intel graphics. That sucks. Is this true?"

    As per Razer's website, on mid-2019 RB (Advanced) USB-C (thunderbolt) as well as mini-DP and HDMI are connected to the Nvidia graphics card directly and thus able to output display information, which you can yourself test with an USB-C to Displayport adapter cable.

    However, you don't get any benefit from connecting it directly to GPU since Oculus Link is treating the connection as normal USB-data in order to also facilitate also sending back information (with a single cable connection) from the headset, like for example information from the sensors and controllers.

    So as long as you're connecting it to a USB 3.0 or 3.1 capable port with USB-A, (so either directly on the laptop or through a fast enough hub), you can connect Oculus Link with a USB-A to USB-C without problems and this is my own preferred way of using it without taking a precious USB-C port which I need for a high resolution display.

    Regarding your problem with FPS, did you have a look at whether your GPU and CPU is being stressed from task manager while running Oculus Link?
    And were you running other tasks which require high USB bandwith at the same time, such as copying files from a USB-3 external SSD or similar.
    Also if you happen to have an USB-A to USB-C cable (USB 3+ data transfer compatible) can you please try if it works any better when using a different connector on your laptop :)
     
  6. DaiBach99

    DaiBach99 New Member

    See my previous post, connecting via cable seems not to use the nVidia GPU or eGPU, either with the Oculus official link cable via USB-C or a high speed Anker USB 3.1 USB-A to USB-C cable. The Oculus app shows the link is high speed USB3 but when you try and use it the graphics tear, stutter, framerate is single-digit, and it crashes most of the time. This is not a resource issue on my laptop or cable, it's not doing anything else, and if I connect via WiFi instead, it will use the eGPU and I can run Half-Life Alyx in Ultra Quality at smooth framerates.

    Interested that you say it works fine on your laptop with USB-A to USB-C cable - what model do you have?
     
  7. TheParadyme

    TheParadyme New Member

    That sounds very strange. I'm not so familiar with RB-A (2019) but is it possible to somehow disable optimus and just use the dedicated GPU?

    As for what model I'm using, for laptop it's the new Razer Blade Pro (2020) with the top specs.
    And for the cables, I'm using a standard regular 3m USB-A to USB-C cable as well as using a 5m active amplifier extender cable from some random company that had decent reviews on their cables (Newzerol). Connection is also going through an Amazon Basics powered 10-port USB-A 3.1 hub.
     
  8. DaiBach99

    DaiBach99 New Member

    Joikansai posted above that they fixed this in the 2020 model and USB is now linked to nVidia GPU. Unfortunately doesn't work on previous models. I created a support ticket, let's see what they say.
     
  9. TheParadyme

    TheParadyme New Member

    Please note that I'm not connected to the USB-C or Thunderbolt ports which are connected to the GPU.
    I'm using a USB-A connector on the laptop, which is not connected to either iGPU or the main GPU, and even then it's through a hub that does not support standard graphics signal (HDMI / DP) passthrough.

    The reason that it's working means that Oculus Link is packaging all of the graphics data into standard USB-data stream, rather than sending HDMI or DP compatible signal, but through an USB-C connector.
    This is also where the connector linking to GPU or iGPU could theoretically cause a difference.

    Edit: Sorry that I can't give you a direct solution to the problem, reason I brought up my case is that as I've confirmed I've not connected an USB either to GPU or iGPU, it seems like the issue is less of a connector problem but more of a software / driver issue with Optimus being triggered despite load on the GPU.
     
    Last edited: Aug 10, 2020
  10. DaiBach99

    DaiBach99 New Member

    Yes - I think it's an internal chip architecture problem that may have been resolved in the 2020 model, in this case I don't think there is a solution for owners of the 2019 models, but let's see what Razer respond with. Thanks for your input - everything is learning :-D
     
    TheParadyme likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >