Problem with RAZER RIPSAW HD

Discussion in 'Razer Support' started by TheLousyLoser, Apr 16, 2021.

Thread Status:
Not open for further replies.
  1. TheLousyLoser

    TheLousyLoser New Member

    I made this short vid (sorry for the bad quality but so it's not too big to share) to show you my problem with my RAZER RIPSAW HD capture card.

    1382986128270184449 is not a valid tweet id


    When streaming and recording I always have this flickering screen. Only on the streaming pc, not on the TV. So I think there is a problem with the connection or some setting between PC and capture card. I tried a different USB cable but that doesn't worked.

    I use OBS Studio for streaming and recording gaming content. The problem is not only on Nintendo SWITCH but also on PS5 and all other consoles which are connected to the RAZER RIPSAW HD.

    Settings (as recommended by RAZER) in OBS Studio:
    - Resolution/FPS type: Custom
    - Resolution: 1920 x 1080
    - FPS: 60

    I tried different settings but no one worked. The drivers are up to date.

    Please tell me, if you need more information to solve this problem.

    Thank you so much!
     
    Vrieze_Knight likes this.
  2. Vrieze_Knight

    Vrieze_Knight New Member

    I'm having the same problem. I've tested with my AVerMedia LGX capture card. and it will stream just fine. the new firmware update has bricked the Razer Ripsaw HD. and I need help fixing this.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >