Problems with Razer Kraken Kitty Edition

Discussion in 'Razer Support' started by juliexhime, Sep 3, 2021.

Thread Status:
Not open for further replies.
  1. juliexhime

    juliexhime New Member

    Hi everyone. I usually plug the USB for my Razer Kraken Kitty headphones into one of the USB slots of my Razer Base Station V2 Chroma. When I'm not using my headphones for gaming, the mute button works normally. But recently I noticed when I use Discord or game (ex. Valorant), my mute button does not work at all. It's very frustrating because my husband has the same items as me but he does not face this issue. If I mute the mic before I hop on discord or game, it'll stay stuck like that until I either close out all the applications or sometimes plugging and unplugging works. I tried using the other USB port on the Base Station but it still has the same issue. I even tried plugging it into my PC, but it still faces the problem. All my Razer items are up to date and so is my computer. I know that this is not a big deal, but it is definitely annoying, especially when I need to say something to private to my husband when we're gaming with friends. I don't want to end up buying a whole new headset since this was a gift.
     
  2. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    It's indeed an issue. I would also not want others to hear when I want to talk privately. You've mentioned that the persists even when the Razer Kraken Kitty is connected directly to your computer. Please disable/close the Razer Synapse while the device is plugged into the computer and check if the issue continues. Otherwise, submit a case or send me a PM so I can help assist you further. I'll be locking this thread now.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >