Razer 8k - Cold Boot Issue

Discussion in 'Mice and Surfaces' started by hitPeachYellowgarden087, Feb 14, 2021.

  1. Quite the annoyance when booting up ~ the Razer 8k mouse is never detected and I have to replug the mouse for it to work every single time. I replicated this by turning off computer for 5 mins and turned it back on.

    I've tried different USB ports, having mouse at 1000hz, disabled fast boot in BIOS. Apparently this is a common issue with Razer mice in general from the past.

    -X570 Motherboard (F33a BIOS Agesa 1
    2.0.0)
    -5950x CPU
    -Asus RTX 3090 Strix
    -Latest AMD Chipset Drivers (Feb 4, 21)
    -Windows 20H2

    General consensus is this a Firmware Issue.

    If you are experiencing this issue, please post I. this thread with your system specs.
     
  2. bobditts

    bobditts New Member

    I have this exact same issue. Extremely annoying. To the point I might return the mouse. I have looked in synapse 3 for a setting and have found nothing. I have also tried using the USB port on the brand new BlackWidow Elite and the same result. The Razer keyboard powers on and responds just fine but the mouse is dead until I unplug and replug it back in. There has to be a fix!?!?!?!? SO FRUSTRATING!!!

    System Specs:

    - Asus ROG STRIX X470-F Gaming BIOS Version 5837
    - AMD Ryzen 7 2700X
    - 64 mb Ram
    - GeForce RTX 2080

    Edition Windows 10 Pro
    Version 20H2
    Installed on ‎7/‎16/‎2020
    OS build 19042.804
    Experience Windows Feature Experience Pack 120.2212.551.0
     
    Last edited: Feb 25, 2021
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >