Razer Blackwidow Elite Volume wheel problem

Discussion in 'Razer Support' started by ICookixz, Oct 29, 2020.

Thread Status:
Not open for further replies.
  1. ICookixz

    ICookixz New Member

    Timochan27 likes this.
  2. TheManTheMystery

    TheManTheMystery New Member

    I've got the exact same issue with mine.

    Hoping to get a fix soon :slightly_sad:
    Mikable1 likes this.
  3. boogieman136

    boogieman136 New Member

    same problem here, exactly as in the clips, any fix?
  4. Zorobuster

    Zorobuster New Member

    same here it was working fine a couple days ago, but now it just stopped working suddenly please fix this asap
  5. ArunasP

    ArunasP New Member

    Have the exact same problem, which makes the scroll completely unusable.
    Mapping the commands to a different button results in same behaviour. For example, mapping the scroll wheel to "A" and "B" and turning it just in one direction results in: aabaaabbabbabababaaabbbaaababababab
    Timochan27 likes this.
  6. Zorobuster

    Zorobuster New Member

    ok a little update on the problem. I switched to razer huntsman te for a little bit because the colume wheel on the razer blackwidow elite stopped working out of no were but, switched back because I prefer the razer greens over the optical reds, I plugged everything in and the volume wheel started working again out of no were. I didn't uninstall the razer program or anything, I literally did nothing and it suddenly wanted to work again..................
  7. Timochan27

    Timochan27 New Member

    I have had EXACTY the same problem for the last 4 months! I hope its not wrong to be happy that I'm not the only one! Upon a lot of testing I figured that its most definitely not a software related problem, instead a mechanical problem.
    Here's a short explanation:
    The Volume dial works like this: two lasers and two receivers and one wheel with a pattern of holes through the middle. As the wheel turns, the receivers detect the lasers (through the hole) and then doesn't detect anything (no hole). The receiving and not-receiving tells the keyboard that the wheel is turning and how fast it's turning. The distance between the lasers (respectively the receivers too) are ruled strategically in relation to the distance between the holes in the wheel for the keyboard to know in which direction the wheel is turning. (ba dum, ba dum, ba dum -OR- dum ba, dum ba, dum ba)

    Now the keyword is *DUST*.
    if dust or any other crumbs or debris gets involved, it can block the lasers passage and therefor making the receiver see strange patterns: ba dum, dum, ba dum, ba dum, bum, ba dum

    This is my best explanation. So If you want your problem fixed have a go at it with a compressed air cleaner. I have not tried this myself yet since I don't have one right now at home. They tend not to be very expensive and aren't hard to find.

    "ba" = receiver Nr 1 detects light
    "dum" = receiver Nr 2 detects light

    EDIT: @pies666 proved that the potentiometer is NOT optical (no lasers and no receivers), however i was still correct about it being a mechanical problem and isn’t software-related. See his comment down below.
    Last edited: Nov 23, 2020
  8. Staffy1976

    Staffy1976 New Member

    Timochan27 is right on this one. I went to town with some compressed air and now it is working like a champ.
  9. Timochan27

    Timochan27 New Member

    I'm happy it worked out for you. Sadly It didnt make a difference for me when I tried. May I ask: did you disassemble the volume dial before spraying it with air, or did you just aim inbetween the crevices?
  10. pies666

    pies666 New Member

    This is wrong explenation.
    I disasembled my keyboard and the volume sensor IS NOT OPTICAL.
    It is a kind of mechanical potentiometer with steel plates. The plates get rusty and start to malfuction. Probably sometimes it just get a little bit dirty and compressed air will help but it's not long-term solution.

    So everybody with this issue - you HAVE TO DISSASSEMBLY your keyboard (2 screws underneeth keyboard rubber pads (tope ones) + lots of screws under the keys). Then You have to unplug the potentiometer itself and disassembly the petentiometer which is kinda tricky. You can do it but it's not easy job. Be carefeul to not brake any parts. When You have steel plates visible I reccomand to clean them with ipa (isoprophyl alcohol) - as I'm from Poland I did it with pure vodka + deminaralised water.

    To clarify - it's not user fault - it's device flaw. It's not user's dirt getting underneeth. It's some kind of oxydation/rust on those small metal plates.
    HanaLover likes this.
  11. pies666

    pies666 New Member

  12. Staffy1976

    Staffy1976 New Member

    I guess I got lucky as I did not need to disassemble the keyboard. I used the compressed air around the wheel along the crevices on the top part of the keyboard at first, which did not make much of a difference. Once I came in from the side of the keyboard and shot the air axially along the wheel base did that make a difference. I will probably have to take it apart at some point, but at least not at this time.
  13. Timochan27

    Timochan27 New Member

    @pies666 thank you very much for your correction. i’ve never seen this metal plate kind of technology — very interesting!
    your method seems quite credible. which piece is the one that has to be cleaned in the picture that you sent? i’m guessing bottom left..?

    Edit: does one have to tear the rubber pads off to get to the screws?
    Last edited: Nov 23, 2020
  14. pies666

    pies666 New Member

    Yes, clean the part in bottom left corner with tape connected. I had the same technology in my '99 Audi TT's heated seats potentiometer. They failed after 15 years :)

    Yes, You have to tear rubber pads but only two of them. One under the ESC button and second one under potentiometer (+- few cm). To be precise - you can tear only half of the pad (no need to tear entire as the screw is near the middle of the pad).
    Timochan27 likes this.
  15. fellbladexd

    fellbladexd New Member

    I can confirm that this is in fact a mechanical issue, although I disagree that oxidization is the problem. I had this issue out of the box on my new Black Widow Elite. Having owned many razer products (sometimes you get one that works on the first go) and other keyboards with similar mechanisms, I immediately tore down the keyboard to assess the issue. Instead of dust or oxidization, the potentiometer had been treated with what looked like lubricating grease, though a very thick veneer of it. Simply removing it with IPA solved my issue. While I do believe throughout the ownership of one of these keyboards that liquids, dust, and other contaminants will cause the same issue to eventually arise, it didn't account for the problem mine had out of the box. It is possible these units are assembled with lubrication to act as a bearing between the potentiometer and the disc and eventually, like my unit did, the lubricant builds up in certain areas and causes the pins to push away from the disc. If someone has this issue out of the box, ask for an RMA, unless you are confident enough to remove the grease yourself. Some people may never have this issue because perhaps the lubrication is very minimal. My unit had quite a bit.
  16. I have the same problem.

    I asked Razer Customer Service about this issue.
    We had exchanged many emails, finally Razer CS told replace team will be keep in touch me for guiding replacement process like how to shipping and contact Fed Ex and so on.
    But after that, another CS guy contacted me and he told me to get an exchange through a reseller, since my keyboard is still in warranty.
    I asked them why I contact reseller and explain them the same issue again that I already said to Razer CS.

    I don't understand why I have to do that.
    I think, Razer CS confirm the issue and they should do RMA.

    Am I misunderstanding the process?

    2 days passed since last mail, but they have no response yet.
  17. ArunasP

    ArunasP New Member

    It was actually rust o_O

    Revisited this thread and after reading other comments, I thought no way. The problem has developed within a month of purchase for me under normal office conditions, no way for stuff to oxidise. I disassembled the keyboard and partially disassembled the scroll wheel (couldn't do it fully and get to the actual plates, as that requires T1 screwdriver, and my electronics set only goes as low as T2) and could see clear marks of rust. A few treatments with alcohol / compressed air fixed the issue.

    That being said, there must have been some serious factory issues or the lubricant must be really messed up for parts to just start rusting...
  18. Staffy1976

    Staffy1976 New Member

    I initially got it working with compressed air, but the problem came back in a couple of weeks. So I used the same method to fix the drift on my Nintendo Switch controller. I irrigated it with contact cleaner a couple of times. I did not disassemble anything. It has been close to three months and it is still functioning as well as the first day I used it.
Thread Status:
Not open for further replies.
Sign In with Razer ID >

Don't have a Razer ID yet?
Get Razer ID >