Razer Blade Stealth 2020 can see hard drive but won't boot from it

Discussion in 'Razer Support' started by KishenLionheart, Jun 29, 2022.

Thread Status:
Not open for further replies.
  1. KishenLionheart

    KishenLionheart New Member

    Hello,

    I own a 2019/2020 RZ09-03102 which has a Lite-on 512GB SSD. Two things have happened in the past few hours and I'm not sure which has caused the issue.

    First, let me explain what was happening.

    1) I was running a Windows 11 update (I'm on the Insider Program on the Release Preview Channel and it was loading an insider build). The update had downloaded and I only had to restart my computer.

    2) I just bought a toolkit to open up my laptop (for the absolute first time) so I could blow the dust out of the chassis and hopefully quieten down the laptop as it's been sounding like an air plane for a while. I opened the panel, disconnected the battery, grabbed a vacuum cleaner and gently lifted away whatever I could before I used a can of compressed air to clean out the rest. Closed it up again and restarted.

    Now, when I rebooted, the machine didn't do anything for a few seconds, then it said it was "restarting" and finally went into Windows. I thought it must have been because of the battery being unplugged but I had forgotten that there was a Windows update too. Started using the laptop and within 5 to 10 minutes, I got a Green Screen error saying the Windows Insider build had a problem and needed to restart. This happened a couple more times before it because a Blue Screen. Then it got to a point where multiple restarts later, I am now unable up boot my computer into Windows. It just boots straight to the BIOS and I can't do anything more.

    In the BIOS, I can see my hard drive under NVMe Configuration in the ADVANCED tab and on the SECURITY tab as well, but it is not showing up on the BOOT tab under Boot Option Properties. I tried switching off Secure Boot and enabling CSM which then showed me my drive after a restart, but it still won't boot from it.

    Is it possible that the drive or the boot record is corrupted by a poorly applied Windows installation? Any chance of recovering from this? Data isn't an issue, I'm happy to format. I just need a working computer.
     
  2. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Yikes! Sorry to hear that the laptop is not booting to the Windows screen. Did you ensure that everything is intact and reattached correctly to the same nodes/connections inside the unit? Try reseating the cables and see if that helps. Also, you may check this article. Go to the Advanced tab, select NVMe Configuration, and choose Optimized Defaults, then save and exit.
     
  3. KishenLionheart

    KishenLionheart New Member

    Hi @Razer.Speedcr0ss. Yes, I've seen that link already and it was one of the first things that I tried.

    I tried the hardware section first and as I said above, the drive is recognised by the device but it is not showing up under boot options.I even tried re-opening the drive and unplugging and reseating the power connector and the SSD (which I had not touched the first time), but with no luck.

    I then tried the software route, thinking the Windows Update might have been interrupted by my unplugging of the power to the board, so I went into recovery using a bootable drive I had lying around and tried to revert the updates, but the recovery tool couldn't find anything to revert.

    I'm now trying to get my hands on another computer to I can make an official recovery disk using the official image for my laptop, but I'm not sure if that's going to work... will post here again if I have any luck.
     
  4. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    I appreciate it. Please divert your update via PM. I'll update this thread once we've finalized everything. I'll be locking this thread for now.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >