Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer Blade Studio Edition 2019 - Completely Blackscreen after BIOS Update

Discussion in 'Razer Support' started by sn0wm4n0, Nov 30, 2020.

  1. sn0wm4n0

    sn0wm4n0 New Member

    Hello Razer-Team,

    I've a big issue with my Razer Blade Studio after I restored my system and updated my BIOS from v.1.03 to v.1.05.

    I followed this instruction: http://drivers.razersupport.com//in...ownload&downloaditemid=4079&nav=0,350,933,945 (after I installed Quadro Studio Drivers 456.71).

    After the update (step 8) I have a completely blackscreen without the Razer-logo and backlight. There's no reaction to F1 or DEL. The Razer Blade does startup (without any picture) and after 10-20 seconds, reboots automatically and stills freeze on fully blackscreen. The backlight of the keyboard still working, but there's no reaction to Cap-Lock. I tried to restart the laptop a few times, but it doesn't help. External Monitor on HDMI Output doesn't send a signal.

    Any thoughts how I can fix this issue?

    EDIT: The solution is on the page 2. So if you have a same issue and your warranty is run out, try to follow and understand the steps. Don't speed up, try carefully, save the settings and bios files, before you erase and programming!
     
    Last edited: Jan 14, 2021
  2. I have a very similar issue that I post about a while ago. So let's get some official support in this official support forum. To the razer employees reading this, You have to have the fix, but you do need to get started. Tell us what information you need. Tell us what steps to take. Tell us how long you've known about the issue and what's being done about it. Keep people informed.
     
    sn0wm4n0 likes this.
  3. sn0wm4n0

    sn0wm4n0 New Member

    I don't understand why they put a wrong BIOS Update on their official support site on a huge and expensive product? I'm so desperate about this issue.....

    I tried to put the BIOS-Battery out for 20 minutes, SSD, and Battery cable. The issue is the same.

    Razer-Team, can you please help the community to solve this problem and upload the working BIOS file with an instruction how to fix this? Is here maybe a "secret" BIOS reset option? I doesn't found any more solutions for this notebook :slightly_sad: :slightly_sad: :slightly_sad:

    Razer please, help me (us) to turn this masterpiece of notebook on!

    EDIT: It was the installation file, or process. The bios file is OK.
     
    Last edited: Jan 14, 2021
  4. riveralc

    riveralc New Member

    Same issue happened to me Yesterday with my Razer Studio 15"...
     
  5. sn0wm4n0

    sn0wm4n0 New Member

    Hello,

    so here's no support or any idea what I can do for my $4k notebook? So how about the warranty, can my notebook get repaired if i sending it in or should i just throw it away after using this only for 2 months? It's a shame! (I've used 5 years a MBP without any issues)

    Please say something, like we "working on this" or something like that. At first would be cool, if you ban the BIOS update from your support driver site...
     
    Last edited: Dec 9, 2020
  6. riveralc

    riveralc New Member

    Agree!! They show #1 Tech support but this is by far atrocious support for a $4+K laptop...sad. I even contacted them and no response.
     
    blankvin and sn0wm4n0 like this.
  7. sn0wm4n0

    sn0wm4n0 New Member

    Last edited: Dec 8, 2020
  8. riveralc

    riveralc New Member

    I have tried a plethora of methods but no screen, even swapped ssd's. Can't view that post but are there steps to pull the bios chip?
     
  9. sn0wm4n0

    sn0wm4n0 New Member

    Hi again,

    so I ordered the CH341A Programmer and found out, wich is the BIOS chip. On the forums below are some ppl, who got this successful flashed. It seems like its a Razer problem that the BIOS Update brick the system. I doesn't found another working solution. Theres a lot of ppl like us (with other models) and the same issue. Razer changing the whole mainboard if you have warranty (in some countries like its a problem).


    @
    you don't need to pull the whole Bios-chip. You need connect BIOS chip with the clip of the programmer and connect to another notebook.

    So new Razer owner: DO NOT UPDATE YOUR BIOS!

    I will search now for a Bios dump and when the programmer will arrive i'll give it a try. I'll keep you updated.

    P.S. The 2019 Models (Intel 9th chip) seems to get more success of flashing, than the newer ones of 2020 with 10th chip.
     
    Last edited: Dec 9, 2020
  10. sn0wm4n0

    sn0wm4n0 New Member

    Razer no response, but for a $25 mouse u can reply - for a $4k notebook with sucking drivers theres nothing. First and last time for me for a Razer notebook, very dissapointing
     
    Last edited: Dec 11, 2020
    blankvin likes this.
  11. blankvin

    blankvin New Member

    Me too, 6 days ago. They setup an RMA and I sent it back the next day. Was supposed to receive a replacement yesterday. Still nothing.

    Don't even bother trying to get in touch with the customer support, warranty, or RMA teams. I'm pretty sure they're non-existent. My case was finally promoted yesterday to the "Escalation Team" who was supposed to contact me yesterday. Guess what?

    No one contacted me. Been on hold now for over an hour.

    Very disappointed in this company and their lack of support. For $4000+, I expect more.

    More here.
     
    Last edited: Dec 18, 2020
  12. blankvin

    blankvin New Member

    There isn't a "Razer Support".
     
  13. riveralc

    riveralc New Member

    Yeah they couldn't resolve so had to send the laptop back in...on my Blade 15 2020 with RTX 2070 now. After reviewing they actually look close to performance comparing each other...?
     
  14. blankvin

    blankvin New Member

    @riveralc I hope you don't need a laptop because you won't get a repair or replacement for a long time.
     
  15. blankvin

    blankvin New Member

    Even after having my case escalated to the "Razer VIP Response Team", I have nothing. Biggest regret choosing this company.
     
    riveralc likes this.
  16. riveralc

    riveralc New Member

    I have my blade 15 with GTX 2070 fortunately :)
     
  17. blankvin

    blankvin New Member

  18. sn0wm4n0

    sn0wm4n0 New Member

    something new? I still have the f****ng blackscreen :slightly_sad:
     
  19. riveralc

    riveralc New Member

    I returned this item as I could not revive it for the life of me : /
     
  20. sn0wm4n0

    sn0wm4n0 New Member

    @riveralc do you have the same replacement, or you get your money back? I ask cuz maybe u can dump me your bios settings (if you get one studio, that probably works).

    Greetz

    EDIT: you doesn't need a dump for the "right" bios chip. You need the .bin file from the Bios Updater.exe. you can extract this and install the file, if something was going wrong.
     
    Last edited: Jan 14, 2021
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >