Razer Cynosa V2 is unusable

Discussion in 'Razer Support' started by OriginalSongmonkey, May 3, 2021.

Thread Status:
Not open for further replies.
  1. OriginalSongmonkey

    OriginalSongmonkey New Member

    Just recently purchased a Cynosa V2. It worked fine for about 1 day. As soon as it went to sleep the first time after using Synapse to program it, it failed to wake. Now it fails to even be recognized by my computer. I've done everything from uninstalling Synapse to deleting everything Razer from my registry and starting fresh. Nothing works.
     
  2. mccastillo

    mccastillo New Member

    I have a similar issue with my Cynosa V2. Yesterday it just stopped working, mid use. The lights went out and the key inputs stopped working. Tried changing ports, resetting it by holding esc + caps + space bar while reinserting the usb cable (per support site), checked the usb root power management settings (per support site) and I have plugged it into two different Windows computers. Also, Synapse software doesn’t recognize the keyboard is plugged in. All it will do upon plugging it in is the lights flash 3 times, goes off again, and a Windows error message pops up stating that it malfunctioned and Windows doesn’t recognize it. Hoping this thread gets some support feedback. Thanks in advance.
     
    GunZz_BlaZe28 likes this.
  3. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    By failing to be recognized by the computer, do you mean the PC does not detect it at all, or does the keyboard appear as HID device? Either way, please send me the serial number, and if possible, a screenshot of how it appears on the Device Manager.

    *Thread locked to curb the conversation to PMs.
     
    mccastillo likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >