Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer Deathadder Elite - cant change my DPI

Discussion in 'Razer Support' started by scherginhaan, Feb 4, 2020.

Thread Status:
Not open for further replies.
  1. scherginhaan

    scherginhaan New Member

    Hey guys,

    the title say a lot..

    but what i tried:

    - Re installed Razer Synapse 3.0 (nothing changed)
    - Installed Razer Synapse 2.0 (not working)
    - used Tournament Settings (still not working)
    - blocked service = start>service>Razer Synapse Service (not working)

    i can switch the DPI without RS but the default settings are not good for me..

    Please help me fix this.. :slightly_sad:
     
  2. Jenjar

    Jenjar Well-Known Member VANGUARD

    Have you registered the mouse for warranty on the Razer ID Site (located here) to insure the mouse if not a knockoff? (If you brought it from a reputable reseller it should be legit).
     
  3. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Thanks @Jenjar! Allow me to take over.

    Hi scherginhaan! Was everything covered? Feel free to send me a PM together with your mouse serial number should you need additional assistance.
     
  4. scherginhaan

    scherginhaan New Member

    I contacted support and they were able to help me to a limited extent. My mouse firmware was out of date. Support sent me a 1.06 version, but it is buggy. (My version was 1.04) I couldn't boot it, so I looked for version 1.05 on the Internet. I found it and it worked right away. You have bugs in 1.06, best to revise.

    best regards
     
    Razer.SpeedCr0ss likes this.
  5. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Hey there! Thanks for keeping us updated. I appreciate the feedback. This will help us a lot in improving our products and services. And yes, the FW version 1.05 addresses polling rate, DPI and LED issues. Feel free to send me a PM should you have inquiries or concerns.
     
  6. Kaliega

    Kaliega New Member

    hello, i have the same issue with my deathadder elite, when synapse is turned off the dpi buttons work and dpi change itself but dont know the value, this is the same problem that Mr. Scherginhaan got. Can i ask for help?
     
  7. scherginhaan

    scherginhaan New Member

    hey Kaliega, read my last theard. you can fix it with firmware version 1.05.
     
  8. Kaliega

    Kaliega New Member

    I try. 1.05 give me value cant be 0 error, 1.06 cant run totally. Send files to friends and they Got same problem as me. Cant run fix firmware. Got win10 with latest updates.
     
    Last edited: Apr 22, 2020
  9. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Hi there! Send me a screenshot of the error message via PM. Save it the file via Google Drive or another online drive account then send me the link. Let's continue from there.
     
  10. Kaliega

    Kaliega New Member

    just send PM
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >