Razer Deathadder mini stopped working properly

Discussion in 'Razer Support' started by RisingTwilight, Nov 16, 2020.

Thread Status:
Not open for further replies.
  1. RisingTwilight

    RisingTwilight New Member

    Hello everyone, (sorry its my viper mini)

    My mouse has been working amazing up until today (~2 months after I ordered it), it has been tracking, and then it won't anymore.

    My laptop recognizes it because the chroma still works and I can right-click, but it won't track. I tried resetting my laptop and it worked for maybe 5 seconds before it stopped tracking again. I did a restart and a shutdown worked for about another 5-10 seconds and stopped tracking again.

    It's not my USB port because I tried a different mouse and it works fine. I also don't have a calibration pad so it's not that either.

    If someone could help me that would be great!
     
    Last edited: Nov 18, 2020
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >