razer electra v2 usb stop working

Discussion in 'Razer Support' started by PuceRedsmartretro682, Apr 20, 2019.

Thread Status:
Not open for further replies.
  1. Hi. i bought razer electra v2 usb few days ago. headset working some time but then sudenly stop working. this occure sometimes in few minutes sometimes in few hours. head set is visible in win but no sound. Only solution working for me is unplug and plug again to work. i have tried clean install synapse 2( no effect). tournament drivers (no effect).uninstall other sound devices like onboard sound card ( no effect) is there solution? im win 10 64bit ver.1809.
    Also i upgrated firmware to ver. 14 ( no effect)
     
  2. Razer.FatKidWanderer

    Razer.FatKidWanderer Just wandering around...

    Hi there, @PuceRedsmartretro6821 Have you tried connecting it to another computer to isolate the issue? Also, is this happening on all of the applications on your computer?
     
  3. hello. sometimes it stop when im watching videos , sometimes when im playing games. its random. i just uninstall all razer software and its better.yesterday it work almost all day without problem, only at evening it stop work again. i think it was when i played star citizen. iwill try test it at another computer.
     
  4. Razer.FatKidWanderer

    Razer.FatKidWanderer Just wandering around...

    I see. Can you send us the serial number of your Razer Electra V2 USB through PM? Make sure to include the link of this thread. Let's continue from there.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >