Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

razer electra v2 usb stopped working

Discussion in 'Razer Support' started by ONYXthinkPalmLeaf201, Sep 2, 2019.

Thread Status:
Not open for further replies.
  1. hello!
    Ive had my Razer Electra v2 headset for a couple years now, and suddenly while playing video games last night the sound cut out completely.
    issues:
    • i can no longer hear out of the headset at all
    • when trying to change the sound volume it will only allow 0% or 100%, yet neither of these produce any sound
    What I have tried in order to fix it, with no results:
    • changing usb ports
    • restarting the pc
    • updating the drivers, as well as updating my PC (windows 10)
    • uninstalling everything to do with Razer, and reinstalling
    • making sure the Razer Headset is set as the default device for playback
    • Checking the headset is actually working, It still lights up and is working fine on other computers
    • ive also used cheap dollar store headphones on my computer, and the sound is fine
    Please let me know how to fix this issue!
     
  2. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Hi there! Thanks for posting your concern here. Sorry to hear about your headset's concern. Just to verify, your headset is working normally when it is connected to another PC? Please send me a screenshot while showing your PC's device manager so we can check if the headset's driver is correct and present.
     
  3. leetCerulean909

    leetCerulean909 New Member

    I have exactly the same issue and i have tried everything :/
     
  4. Yes it work(ed) on another computer when trying it last time, but since going to double check it is having the same issue I am having on my current computer ://
    upload_2019-9-3_14-25-25.png

    Here is my computers device manager with the Razer headset plugged in,
    upload_2019-9-3_14-26-9.png upload_2019-9-3_14-26-30.png

    as well as the general and driver properties
    anything helps, so let me know if you need any more information
     
  5. Eustace_8

    Eustace_8 New Member

    i have the same problem tonight
     
  6. Eustace_8

    Eustace_8 New Member

    upload_2019-9-15_1-15-56.png
     
    NSRobb likes this.
  7. Eustace_8

    Eustace_8 New Member

    in device manager even the name of headphones not writing... pls help me
     
  8. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Hi everyone! Thanks for the details. This is definitely not our headset's normal behavior. Please send a PM, let's continue from there.
     
  9. NSRobb

    NSRobb New Member

    hello ! I have the same problem
    upload_2019-9-28_19-50-33.png
     
  10. GuiNerd

    GuiNerd New Member

    Hello, I have a similar problem. But in my case windows identifies the headset, but it does not turn on, the led does not work, it does not play sound and the microphone also does not work. Already tested on another usb port, already tested on two other computers, already reinstalled the driver, it seems that it stopped working, and I bought it has 5 days.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >