Razer Hammerhead TW Right side not working

Discussion in 'Razer Support' started by InversedStar, Aug 2, 2021.

Thread Status:
Not open for further replies.
  1. InversedStar

    InversedStar New Member

    I bought the Razer Hammerhead TW a couple days ago, and they just got here today. I took these out of the box and I had charged them up fully before taking them out (green light on case). I had paired them to my phone and was only able to hear sound from the left one. I put them back into the case, let them fully charge again and tried again with the same results.

    I then tried to disconnect by pushing and holding both for 6 seconds, and then double tap on both earbuds to pair them. That did not work either. I attempted pairing them with the Razer Audio app, but it cannot find the headphones to connect in the first place despite it being able to pair using my phone's bluetooth.

    I tried connecting to my computer and got the same results. I had tried resetting, and disconnecting and pairing with the touch buttons, but I still receive absolutely no sound from the right earbud.

    I have a samsung galaxy fe s20 and am running windows 10. This sucks is my final assessment on these earbuds, but what can I do? I also want the app to be working because that is part of the reason why I was interested in these earbuds in the first place.
     
  2. Razer.GuitarScar

    Razer.GuitarScar Active Member Staff Member

    Hello there! Let's try to isolate the behavior by following the steps from this page. If that doesn't help, send me the serial number of your device via PM. I can use it to verify its model and look into possible solutions.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >