Razer Huntsman and unstable behaviour in Synapse 3

Discussion in 'Razer Support' started by Xrayshot1, Jan 30, 2019.

  1. Xrayshot1

    Xrayshot1 New Member

    Hi everyone

    We bought the Razer Huntsman a few weeks ago and installed Synapse 3 along with it to activate all the bells and whistles.

    Sadly the functions are very unstable. Most of the time the keyboard isn't detected by Synapse and doesn't appear - and when it occasionally does and we get to pick a lighting effect, the keyboard either ignores it or it starts up only to freeze after about 2 seconds. Switching USB port will in some cases reactivate the lighting effect and it might stay on for a while, but as soon as we change some setting in Synapse, in which I assume the software needs to communicate with the keyboard, the keyboard freezes.

    Generally, trying to reset or save a profile to memory always fails and keyboard freezes.

    We've tried different USB ports but the behaviour stays the same.

    We've un- and reinstalled Synapse but it didn't help. It stays unstable and sluggish.

    It was a gift for my son and his dad is looking more and more stupid by the day, so please help us out. :)

    Thank you!
     
  2. JAVIELITE

    JAVIELITE New Member

    no solution here synapse is a lot unstable, the worst soft i never used in all my life, nor razer not problema easy. if you can back razer made it and buy corsair or logitech
     
  3. Xrayshot1

    Xrayshot1 New Member

    Thanks Javielite, but I really hope that the official Razer support are of a different opinion... ;)

    Razer? Guys?
     
  4. JAVIELITE

    JAVIELITE New Member

    then you can start praying
     
  5. DMuehlhausen

    DMuehlhausen New Member

    I'm having similar issues. It's nothing breaking, but sometimes the coloring stops working or even the volume control knobs. Just now I adjusted the volume up, but I can't take it back down. Now I"ll have to reboot, or reconnect the cables to get it back and that doesn't even always work. I can still adjust the sound via the control panel or physically on the speakers, so it's not a Windows issue.

    I've removed and updated the synapse software. I've reinstalled the keyboard. Nothing seems to fix it
     
  6. titituit90

    titituit90 New Member

    same with me. i bought razer hunstman elite and firefly cloth back in december and i got the same problem with Xrayshot1 and DMuehlhausen. yesterday i uninstall and re-install synapse 3 nothing different, my keyboard and mousepad didn't detected. dear razer can you fix our problem?
     
  7. DMuehlhausen

    DMuehlhausen New Member

    My devices are detected, though the wrist pad doesn't always get picked up. Normally just rebooted fixes my issue, at least for a little bit. It's a shame cause I love the feel of the Opto-Mechanical keys and want to get another Elite for work. Though one of the main reasons I want it is for the volume control. Not really worth 200$ if it doesn't work half the time :)
     
  8. Frehley

    Frehley New Member

    any solution here i have the same problem
     
  9. DMuehlhausen

    DMuehlhausen New Member

    No, but of course if you contact Razer, even though there are plenty of people here having the issue, they act as it's a probable hardware issue. which I don't think it really since other people are having the exact same issue.
     
  10. Xrayshot1

    Xrayshot1 New Member

    No solutions yet and still no response from Razer. I thought this was an official support forum with Razer moderators, or am I wrong?
     
  11. Xrayshot1

    Xrayshot1 New Member

    To give credit where credit is due - since the latest update to Synapse everything has started working, so thank you Razer.

    We haven’t changed anything in regards to configuration or ports or whatever. Hope this goes for the rest of you as well.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >