Razer Huntsman elite dead???

Discussion in 'Razer Support' started by CR4M4LH31RA, Jul 14, 2021.

Thread Status:
Not open for further replies.
  1. CR4M4LH31RA

    CR4M4LH31RA New Member

    Hi guys
    I'm new here and probably my English it's not perfect because I'm Portuguese but I hope somebody can help me on this situation.



    I already have dismounted the keyboard cleaning everything but the problem remains. I choose the reactive profile on synapse and in the video you can see the keys with problems , they activate by them self but when I tried to press the Enter or other key of those they simply doesn't work.
    Hope you can help me, my Garantie was finished like 3 months ago

    Thank you all.
     
  2. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Was there any incident that occurred before the issue? Have you tried connecting the Razer Huntsman Elite to a different USB port or computer? Please check if the behavior continues while the Razer Synapse 3.0 is closed or disabled. Feel free to send me a PM should you need additional assistance.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >