Razer Huntsman V2 WASD phantom keys

Discussion in 'Razer Support' started by brettapuss, Sep 16, 2021.

Thread Status:
Not open for further replies.
  1. brettapuss

    brettapuss New Member

    so im on my second Razer Hunstman V2 Analog as of today. i had high hopes to finally have a working keyboard since ive been dealing with this issue when i first bought the huntsman V2 over 4 or 5 months ago. i plugged my new keyboard in today and my S key phantomed/got stuck within an hour of being out the box, this btw is on a brand new PC with a fresh windows install with nothing other than the OS(win10), razer synapse 3 and Halo the master chief collection installed.

    i dealt with this issue for 4 months literally because i dont know how to search for this issue i couldnt find anyone else with this issue and razer just told me it was an issue with my keyboard and theyd send me another one out. upon finding out that the termonology for this is "phantoming" i founth a plethera of posts relating to people having the same issue as me.

    the fact its been happening this long and people are still having this issue is insane, these keyboards need to be recalled. im going to be contacting razer tomorrow about this trying to get a full refund because the fact they have 0 urgency to fix this is a joke. this is a £250 keyboard that seems to be broken for hundreds of people. im not that wealthy this isnt something i can just shrug off and think oh well ill get another keyboard. this is an investment for me into the hobby i love and the fact that a huge amount of my money has been wasted on a product thats being shipped broken or faulty in the masses and razer must be fully aware of it at this point discusts me.
     
  2. DevilyZ

    DevilyZ New Member

    I am experiencing the same issue, keyboard arrived around 14 sept 21, manufacturing date on keyboard box says 2020 Nov

    First fixed issue, M key not actuating properly, which razer Rupport recommended compressed air that works. doesn't say much about reliability & durability if its out of box issue. but fine it works.

    Second issue, A & D & Enter not registering that the button has been depressed unless you hit it again.
    - Currently working with razer support who claims that this is a "new" issue, similar to how other post all over says their "default" response.
    - Have been recommended to clean reinstall razer synapse which I have done. (doesn't work)
    - Currently trying with razer synapse disabled.
    -- For enter getting stuck , I encountered it once while using chrome, no games on, decided to experiment and I tried disabling razer synapse and it does stop registering. so i am pretty convinced that disabling razer synapse should work. however most of the features i paid for the keyboard is based on razer synapse , so its a lousy situation
    - My seller says they wont do anything unless razer acknowledges the issue. so I am stuck haha

    @mod , please do NOT close the thread, let the thread live until a solution has been actually found and put the solution in the actual thread itself. It seems to be a common issue, as there are a few threads in this forum , and multiple on reddit already. nobody has a solution yet, only a workaround.
     
  3. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hi brettapuss! Apologies if this has been an ongoing issue already. The team endeavors to generate a resolution. By the way, does the issue happen while the Razer Synapse is disabled or closed? Please follow the steps from this link. Otherwise, submit a case or send me a PM so I can help you create a case on your behalf

    Hi DevilyZ. I appreciate your feedback. Please send me your email address or case number so I can check its updates/history via PM. Let's continue our conversation there.
     
  4. DevilyZ

    DevilyZ New Member

    Hi Speedcross , my case number is (*Omitted for security purposes)

    No worries, I prefer to chat here unless there is specific private information. what we discuss might help someone else get closer to the solution and likewise they may help contribute potential solutions.

    I have left a comment on a youtuber's account and he mentioned he encountered the same sticky keys and has recommended updating the actuation point to potentially eliminate the issue.

    Things I am going to try out
    - Without Razer synapse
    - With Razer Synapse & deeper actuation point
    - Last resort, Removing all my other razer stuff & clean reinstall, hoping that this isn't the solution, have like 11 razer items connected now. Took 1-2 hours to set things up after the last reinstallation because my profiles somehow didn't get saved into the cloud, especially the addressable RGB controller.

    For each item , I am going to test for at least 5 hours of gameplay to see if I can replicate, if its replicated, then I would move on to the next test.

    This is not a thing that happens often, but when it happens , my character dies. so in terms of reliability, my razer blackwidow elite is more reliable. have seen it around 6 times over 8 hours worth of gaming about 2-3 hours each session.

    I really love the typing experience of this keyboard and hope it gets resolved.
     
  5. DevilyZ

    DevilyZ New Member

    @brettapuss I am testing something that might have some success as a workaround with razer synapse installed.

    In razer synapse > huntsman analog > lighting > change to quick effect , under static. or better yet turn off lights if you don't really care for them.

    So far was trying yesterday (quick effect static purple) and went 4 hours without a stuck key, swapped to razer studio's ambient and "D" was stuck in less then 5 mins. But only more testing can confirm if it works. So do test it too and let me know if you encounter. I will be continuing to test it!
     
  6. brettapuss

    brettapuss New Member

    sorry ive been inactive i honestly didnt think anyone cared at this point
     
  7. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    I appreciate that. Thanks for letting me know. By the way, please refrain from posting any details (personal or device) on threads since it's against our house rules. I've forwarded this to our team.

    Have you contacted our Support Team already? If you haven't, please send me a PM so I can assist you in submitting a case.
     
  8. brettapuss

    brettapuss New Member

    i did pm you but im gonna get into a live chat with razer today to sort this
     
  9. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    I've replied to your PM. Anyhow, feel free to send me your case number or email address privately so I can check your escalated concern's update.

    Hey @DevilyZ. I've forwarded your case number to our Support Team to speed up its progress.
     
  10. DevilyZ

    DevilyZ New Member

    Just an update, (*Omitted) from razer L2 support has contacted me with another fix that includes a patch. Will be testing it out. hopefully it works as intended.

    Since I know the settings which tends to increase the occurrence of the bug. I will be utilizing those settings.

    Will update here in a couple of days after testing. hopefully it resolves it.
     
  11. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Thanks for keeping us in the loop. Fingers crossed. I hope that the firmware patch helps the keyboard's concern.
     
  12. DevilyZ

    DevilyZ New Member

    Unfortunately , doesn't work still , have tried unplugging 5 other razer devices just incase they might have conflict , but still same.

    The patch was really weird though, it didn't show any actual successfully run feedback after requesting admin permissions to run. but according to the razer support it should be installed properly.

    Razer support have requested logs! , have sent it , hopefully they can identify the issue and fix it!

    I wonder if there are newer batches of keyboard that might have accidentally fixed it. Mine belongs to 11 2020 batch according to the box , which i suspect is the first release.
     
  13. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Thanks for letting me. If the troubleshooting steps were exhausted, the final resolution is a device replacement. Anyhow, please continue communicating with the team via email.
     
  14. DevilyZ

    DevilyZ New Member

    So far it seems like the razer synapse update 3.6.920.91710 seems to have fixed it. but along comes other bugs.
    - studio sometimes crash when loading. restarting the app helps.
    -- not major to me since I just need to set it up once and leave it.

    Haven't encountered any issues with about 8 hours of gaming testing with the configurations that I know to cause previous issues.

    Will report back if the issue returns. which is hopefully never !~

    For those who encounter the issue! please update it, while its not perfect, it makes the keyboard usable in games

    @brettapuss have you tried the update?
     
  15. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    That's good to hear. I will send this feedback to the team. Allow me to lock this post now. Should you've encountered the same or another issue, please create a new thread.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >