Razer Keyboard not recognised

Discussion in 'Razer Support' started by uzer001, Jan 9, 2021.

Thread Status:
Not open for further replies.
  1. uzer001

    uzer001 New Member

    My Razer Cynosa V2 randomly stopped working, LEDs turned off and keys stopped responding. In Device Manager it is listed as "Unknown USB Device (Device Descriptor Request Failed)"

    I've tried many solutions to this problem, none of them worked. (Rebooting PC, Updating Driver, Uninstalling Driver and rebooting PC, plugging keyboard into other USB ports)

    Hopefully someone can help me.
    Thanks in advance.
     
  2. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    The USB controller of the keyboard is highly likely damaged. Please send me a screenshot of how it appears on the Device Manager, along with the serial number. I can use those to submit a warranty claim if necessary.

    *Thread locked to curb the conversation to PMs.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >