razer kiyo doesn't work

Discussion in 'Razer Support' started by fastMaximumRedinfo922, Jan 12, 2019.

  1. Hello, I'm having a webcam problem. Suddenly the bottom leds stopped working and then stopped working completely on my PC, but the device manager still sees it as plugged in and functional. And when I plug it into another PC, it works fine. I did not change anything on my PC, nor was there any update.

    Every help will be appreciated. Thank you

    But microfon works
     

    Attached Files:

    Last edited by a moderator: Jan 12, 2019
  2. Jenjar

    Jenjar Well-Known Member VANGUARD

    Have you tried to reinstall Synapse, and have you tried using a different usb port on the PC that it is having issues on?
     
  3. Predator5

    Predator5 Well-Known Member

    Try reinstalling the drivers.
     
  4. yes i reinstal synapse, but sometimes work sometimes not and another problem is here, some LED stop working to.
    I'll probably contact the seller
     
  5. shmekermeister

    shmekermeister Well-Known Member

    Hm, if it works on another PC, maybe there is problem with your PC?
    Try to contact Razer support. Let them try to fix this for you first.
     
  6. yes i contact support but when we fix this problem LED system doenst work too. SO i contact seller and they give me new camera. But thank u all for trying help me
     
    shmekermeister likes this.
  7. LexAeterna

    LexAeterna New Member

    Half of the LED light now no longer works and I just got it for 2 days
     
  8. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Hi @fastMaximumRedinfo922 and LexAeterna, please send me a PM so I can help you further isolate the issue.
     
  9. LexAeterna

    LexAeterna New Member

    Hello sir
    'how to send a PM? hahah
     

    Attached Files:

  10. LexAeterna

    LexAeterna New Member

    Anybody can help me with this KIYO problem?
     
  11. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    I responded to your PM. Please check your inbox.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >