Razer Kraken X Surround Sound Not Working

Discussion in 'Razer Support' started by Xounaut75, Aug 11, 2019.

  1. Xounaut75

    Xounaut75 New Member

    Hey! I just bought the new Razer Kraken X a few days ago, and when I was talking with a few friends over discord they could hear my ingame sound when my mic was muted. I tried fixing this by disabling the 7.1 surround sound in playback devices. I couldent enable it again so I had to reinstall the 7.1 surround sound application. Ever since reinstalling it, I cant hear anything from the 7.1 surround sound other than a little tick sound whenever I play something. I have tried to solve this by reinstalling drivers, reinstalling the surround sound application, changing default devices and troubleshooting with windows. Is there any other way to fix this issue?
     
  2. Xounaut75

    Xounaut75 New Member

    I fixed the surround sound by enabling the internal AUX jax and setting it to default communication device.

    My only problem now is that the mic still plays what I hear to others when I have the mic muted.
     
  3. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Thanks for posting your Razer Kraken X concern here. Kudos on figuring out that the Internal Aux Jack needs to be selected as your default communication device to resolve the no audio issue. For your other concern, have you tried tweaking your microphone's level at Control Panel >Sound > Recording > Properties > Levels? Please ensure that only one voice chat application is in use while in-game. Also, please check if your computer is configured to use the correct recording device under Control Panel > Sound > Recording. Select the proper recording device, right-click on it, and select "Set Default Device" or "Select Default Communication Device". Lastly, ensure your computer supports the combined audio jack. If not, please use an audio/mic splitter cable.


    [​IMG][​IMG]
     
  4. Xounaut75

    Xounaut75 New Member

    Thank you for helping me about the kraken, I have tried everything and it still seems to happen. I feel like it seems to be a speaker problem (with the headset) and not the headset's mic problem. Since the mic is muted, it shouldent be giving out sound, so it has to be the speakers. Even if I try changing the output device it still seems to happen, is there any other thing I should try to do?
     
  5. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Does the issue happen while using the headset to another game or other programs such as Skype that uses video conferencing? I suggest testing your headset to a different computer or to a mobile device and see if the issue persists.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >