Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer Mamba Elite suddenly stop working (Dead)

Discussion in 'Razer Support' started by MasterMariner, Jun 28, 2020.

Thread Status:
Not open for further replies.
  1. MasterMariner

    MasterMariner New Member

    Hi Razer. I experienced problem with my razer mamba elite yesterday. Im in the midle of the game and it suddenly stop. I tried unplugging and replug it but still not working. I tried to restart my computer and I also tried dozens of recommendations I found in the razer forums and reddit and other website that may help but still its not working and now I have two problems After uninstalling razer synapse. I cant install it now.. it is always installation failed with error code 528040. My mouse doesnt have cuts on cables and it is actually on top of my table with a good cable management so i dont see any reason for it to malfunction because of physical damage... I having fun using it and playing my game and then boooom it suddenly stop. I even tried to plug it to my sisters computer and laptop but it still not working and no lights showing. I hope you can help me with my problem. By the way razer keyboard is working and my mouse is the only one not working.
     

    Attached Files:

  2. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Does your PC still detect the mouse? From your description of the issue, the mouse is highly likely dead. What's even weirder is the error message you're getting during the installation of the app. What operating system is your PC running? Do send me a PM with the SN of the mouse so I can check the warranty status.
     
  3. MasterMariner

    MasterMariner New Member

    I already sent you a PM. Thank you.
     
    Last edited: Jul 1, 2020
    Razer.Caziel likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >