Razer Mamba TE Cursor won't move

Discussion in 'Razer Support' started by VKVKVK, Jan 28, 2019.

Thread Status:
Not open for further replies.
  1. VKVKVK

    VKVKVK New Member

    i have 2 razer mamba tournamen edition, i dont know what happen with my mouse. all button perfectly working but i can't move my mouse cursor. i already tried clean the sensor lens with a Q-tip and some rubbing alcohol but still can't working. i already tried to update firmware too 1.0.3, but still doesn't work. please share if u know how to solve this problem.

    btw i already try every tutorial on youtube and google. but no one can solve my problem.
     
    Last edited by a moderator: Jan 28, 2019
    Vinch_CH likes this.
  2. Razer.FatKidWanderer

    Razer.FatKidWanderer Just wandering around...

    Have you tried connecting the Razer Mamba TE to another USB port or another computer to isolate the issue? If you are still having the same issue, please do PM me together with the serial number of your mouse. Let's continue from there.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >