Razer Naga Trinity Key binds go haywire after launching WoW

Discussion in 'Razer Support' started by easyVioletBluebox320, Aug 13, 2022.

Thread Status:
Not open for further replies.
  1. Hi,

    first of all, can I just say the customer support of Razer is bloody awful. You want to contact support? You need to confirm you went through the most basic troubleshooting to prove... I don't know, something. Your mouse is out of warranty? Tough shit, you might as well get a new mouse rather than trying to figure out what is wrong.

    With that rant over. I've recently run into a very confusing issue with my Razer Naga Trinity. I'm using the 7 button swap out side panel and everything works fine for the most part, except when I try to play World of Warcraft. When I log into the actual world my key binds for the side panel suddenly don't work and some of the buttons are mapped to absolutely random buttons, for example my button 4, which I normally have mapped to the keyboard function ; is suddenly a second middle mouse button. When I check synapse, the profile still shows my actual key binds, as do my actionbar key binds in WoW. I've tried re-binding my key binds in synapse while WoW is open but that doesn't seem to solve anything.

    The even weirder thing is that once I close WoW the messed up key binds suddenly persist, without it showing anywhere in synapse. So I generally have to disconnect the mouse and reconnect it for it to start working properly again.

    Before anyone asks, yes I have tried connecting the mouse through various usb connectors (both in a hub and directly into the pc), I've run all windows updates, I've checked for updates with synapse and razer and I've tried exiting all apps through the taskbar synapse logo.

    Would appreciate any tips or pointers on the issue.
    Thanks
     
  2. Thought this info might also be useful, I've gone through my addons in WoW and disabled and reenabled them one by one and none of them seem to have an impact on the key binds.
     
  3. Razer.Zionzedd

    Razer.Zionzedd Yes, My lord? Staff Member

    Try to repair the Synapse application by following the steps here. If that didn't help, let me know through PM so I can start a case and raise your concern with the Software Team for an advanced resolution.

    *Thread locked to curb conversation to PM.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >