Razer Nari Ultimate Pairing Utility Not Working

Discussion in 'Razer Support' started by zoaaaaa, Jun 25, 2022.

  1. zoaaaaa

    zoaaaaa New Member

    I am trying to pair my Nari Ultimate to a new dongle I got, the old one was not working for some reason randomly. After finally getting the dongle, I'm trying to use the Ultimate pairing utility, but it does not recognize the headset being connected via power cable. It recognizes the dongle for step 1, but it does not recognize the power cable for step 2. I have tried multiple USB ports for the power cable, and I have even tried a different power cable. I tried two different computers as well. The problem is that utility never gets passed step 2.
     
  2. zoaaaaa

    zoaaaaa New Member

    Also, I should add, the headset does charge normally. It even seems to be recognized by the computer, but the utility does not recognize it. I have tried uninstalling and updating drivers. I have tried uninstalling and reinstalling Synapse, which I keep closed during using the utility anyway.
     
  3. sulfoncool

    sulfoncool New Member

    where did you get the new nari dongle?
     
  4. zoaaaaa

    zoaaaaa New Member

    I ordered it off Amazon for an overpriced cost from some Chinese company because Razer themselves has it out of stock forever. New dongle ended up being a waste of money because of the problem in my first post. I ended up buying a different headset from Steelseries.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >