Razer Nari Ultimate - THX Spatial Audio Issue

Discussion in 'Razer Support' started by Upgrade01, Sep 10, 2020.

Thread Status:
Not open for further replies.
  1. Upgrade01

    Upgrade01 New Member

    I bought these headphones about a month ago and I'm having issues with crackling/popping while THX is active. I believe I have narrowed it down to Synapse 3 being the cause of the issue. The sound quality improves when I turn THX off but when I do that I don't get 7.1. The second I turn THX back on I get popping/crackling sounds. I can hear what is going on but the popping sounds get quite annoying to the point where I don't even want to use these and go back to my old headset. I have reinstalled the drivers software, reinstalled Synapse 3, deleted registry files, changed USB ports, etc. Another thing that happens is while I'm using the headphones while charging every time there is a loud bass sound the headphones disconnect and reconnect which gets annoying as well. Thank you
     
  2. leadene

    leadene New Member

    this im having this also. i cant find a way to fix this either.
     
  3. TokyoBB

    TokyoBB New Member

    I'm having the same issue but only when I play games. When listening to music, for example, sound quality is great no matter how loud I turn up the volume. Would love a fix.
     
  4. Smeagol251

    Smeagol251 New Member

    Having the same exact issues as well, and still happening on the 2nd pair of Nari Ultimates they sent me.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >