Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer Phone 2 not charging unless Restarted or in Safe Mode + Battery draining faster

Discussion in 'Razer Support' started by Moneyman228, Sep 10, 2020.

  1. Moneyman228

    Moneyman228 New Member

    Recently my Razer Phone 2 will randomly stop charging and won't charge unless I put it in safe mode or restart it. This applies to regular charging as well as wireless charging. The USB port is also loose and won't charge unless its standing PERFECTLY still and pushed in quite hard. The battery also seems to be draining slightly faster then before. I have performed a factory reset and it did not solve the problem. Has anyone had this issue and/or know how to fix it? Really not impressed I'm having battery problems after only owning this phone for a year.
     
  2. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Hi there! Thanks for posting your phone's concern here. When did the issue start? Have you tried using a different cable or tested the Razer Phone 2's charging cable to another phone to isolate the charging behavior? Feel free to send me a PM together with your device's serial number should you need additional assistance.
     
  3. colinrazercolin

    colinrazercolin New Member

    Hello, I'm having the same issue. I bought phone new and have only been using it for 1.5 years. It will not charge unless I restart it and it takes some effort to get the phone to charge. I do not have to push in the cable, I have to pull back slightly to get a more snug fit. The USB-C port is definitely loose compared to when I initially bought the phone. I can no longer use the factory charger as the cable does not work at all. I have an Anker USB-C cable that works, but only after fighting with it for a bit. The battery definitely drains much faster than it used to and is getting worse. I must recharge twice a day if I'm using it. I can almost see the battery count down 1% every other minute while watching a video or playing a game.

    Also, the apps on my phone stopped recognizing Micro SD cards. I have had one in the phone since I bought it, but overnight it stopped recognizing it. I verified it works in other devices. The phone knows the SD card is there, but none of my apps (spotify, Amazon Prime Video, gallery) recognize it's available.

    I'm about ready to factory reset this thing, any chance that will help fix either of these issues?
     
  4. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Thanks for sharing your phone's concern here too. Please perform the steps below and see if it helps:

    • Perform a hard reset by simultaneously pressing and holding the power button and volume up button for 7 to 10 seconds.
    • Check of available software updates.
    Charging/power issue
    Factory reset
     
  5. colinrazercolin

    colinrazercolin New Member

    Thank you. I did the factory reset yesterday and am still having the same problems. Oddly enough, the charging issue is slightly better, but still doesn't charge unless I find the perfect angle to sit my phone down. It is easier to find that angle now, but still not ideal. The cord is not a snug fit. I really believe the usb-c port is somehow warn out. I tried cleaning it with a tooth brush as well. The Micro SD card issue is still unresolved. My phone recognizes there is a sd card, it allows me to format it to be additional internal storage, but it doesn't seem to be formatted correctly. Spotify and Amazon prime video do not even recognize there is a sd card installed. Vudu has an option to use an SD card to download movies onto, but when i select it i received an error message "There is not writable SD card on this device."

    The charging issue began a few months ago, but has gotten progressively worse. i really believe the usb-c port is flawed and degrading. The SD card issue started abruptly yesterday morning. I believe the phone is not properly formatting the card as i tried it on other devices and they were able to format it and use it as internal storage.

    sorry for extremely long response. thank you for the help
     
  6. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    I appreciate your follow-up. I've replied to your PM. Let's continue from there.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >