Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer Phone 2 - Screen Freezing/Locking Up - (AT&T Version)

Discussion in 'Razer Support' started by lifeOlivebyte062, Apr 8, 2019.

Thread Status:
Not open for further replies.
  1. lifeOlivebyte062

    lifeOlivebyte062 New Member

    Ok, so the problem is that my screen freezes locked. When this happens, you can tell the phone is actually
    still functioning, as the vibration feedback from attempting to use the power key still continues to work, but
    the display remains totally blacked-out. Phone will still ring, notification sounds still come through....but nada on
    screen. I have to do a soft-reset (hold power + volume-up key until logo appears) to get it to work again. Whenever I do a reset like this, the AT&T splash sound, as well as the sound that accompanies the Razer Logo, seem overly-loud and slightly distorted. When everything is restarted, the phone functions perfectly, until it happens again.

    I really want to Love this phone, but this issue has gone from slightly irritating, to rage-inducing. I am convinced
    that it has something to do with the Bluetooth, as I have seldom had it happen when it wasn't connected to a device. Devices in question are a Samsung U-Flex, Samsung Gear S2, and Powerbeats3. The only indication that it is happening is that the audio will drop, followed by a single vibration feedback in the headphones....when this happens, phone is always blacked-out when I pick it up to check. This has happened with the phone in my pocket screen-in, in my pocket screen-out, on my desk beside me, on the wireless-charger beside me...never more than 3 feet away. I have also intentionally walked out of bluetooth range until it disconnects, then back into range until it reconnects.....with no issue.

    I have had my phone for almost a month now, and this problem began within the first few days. I have uninstalled all apps that I added since purchasing the phone....did not help. I haven't yet done a factory reset. Running 8.1.0.

    Please help! Like I said I really do want to love this phone....this has been my only issue, but this is a major
    problem for me, as Bluetooth has become a necessity at work, and with the absence of a headphone jack, having to use the dongle daily with a set of wired headphones is not something I am willing to accept out of a flagship phone.....even with the price break!

    TIA to anyone who may be able to help!
     
  2. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hello there! Does the same issue happen when the phone is placed in Safe mode? If you haven't tried it yet, please do. Let me know how it goes.
     
  3. lifeOlivebyte062

    lifeOlivebyte062 New Member

    Retracting the statement about the likelihood of the problem being tied to Bluetooth. Did without and kept it turned off for a day, and I still had the same issue.

    So yeah....this worked. But it leaves me with more questions than answers. Assuming this means that my issue is going to be App-based. Is there any way to know which app is causing the issue without going back to zero and adding apps one at a time until the problem pops up again? Tbh, I was only able to keep it in Safe-Mode over the weekend to test, as I have several apps that I have to use for work throughout the week, so keeping it in Safe-Mode during that time is pretty much impossible....just getting a bit tired of having to reset my phone a half-dozen times a day otherwise.

    Thank you very much for your help btw!
     
  4. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Thanks for the update. The factory reset would be the best way to start from a clean slate. By the way, can you give me the current build number of your phone?
     
  5. lifeOlivebyte062

    lifeOlivebyte062 New Member

    Model: RZ35-0259 Build number: O-RZR-ATT-RLS005

    Thank you again for your responses.

    Pretty disappointing though...Two HTCs (Inspire & One), and two Samsungs (S6 Edge & S8) prior to this device...I guess I expected too much out of this phone. I know no hardware is ever perfect, but I have never had a Schrödinger's phone before...and see no good reason for the issues with this one, especially given that I have very few apps installed (nothing done through .apks), and nothing I didn't have on my S8.

    Would love to figure this out and see this device end up performing well, as I have always been a fan of Razer's products, but I just can't have a phone that might or might not work in an emergency situation b/c I have an app installed that it doesn't get along with?!? Again, coming up on a decade of smartphone ownership with nothing approaching issues like this....and on the second iteration of the phone as well? Fingers crossed that I find an answer soon, otherwise, this one is going back, and I'll be joining the herd.....but at least the herd's phones work! *smh*
     
  6. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Thanks for the reply. Please send over the serial number over to me through PM. Make sure to include the link to this thread as well. Let's continue there.
     
  7. racer8848

    racer8848 New Member

    I am having this issue as well. I bought the phone Saturday and have had this happen at least twice a day each day. I am on Verizon Build number P-MR1-RC003-RZR-190305.3110. I am on Android 9.0. I also have already reset the phone to factory default and started over to no avail.
     
  8. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hello. Please send over the serial number of the phone as well as the link to this post over through PM. Let's continue there.

    Anyone else having the same issue, please send me a PM as well.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >