Razer Ripsaw Freezing/Only working when source set to 480p

Discussion in 'Razer Support' started by technoVividOrchid499, Jan 6, 2019.

Thread Status:
Not open for further replies.
  1. Hey there. I've been streaming for quite some time so I'm fairly experienced with this stuff but this one baffles me.


    First off, I have 2 Razer Ripsaw capture cards that I've been using on my PC for almost 2 years. The reason I have 2 is because I stream tournaments and I have a backup card in case one fails or in case i need 2 streaming setups. They both work perfectly fine. I use them on my other computers without any problems.


    I recently moved my main stream PC from my tournament venue to my home as it was no longer needed there (someone else is doing the streaming from my venue so I brought it home to stream from there whenever I can) and ever since, I cannot get these cards to work on the main PC.

    Here's a video showing what happens:

    Take notice to the distorted image on the bottom and at the end it just freezes. Both cards do the exact same thing. Update: Now instead of getting distorted lines the source will just freeze or go black until I refresh it. it'll come right back up and immediately freeze.

    What I've tried:
    • Contacting Razer
    • Uninstalling and reinstalling the synapse 2.0 legacy application
    • Uninstalling and reinstalling Xsplit and OBS Studio
    • Tested in every known working USB 3.0/3.1 port
    • Ensured the ripsaw was the only device connected to a given USB controller
    • used 3 different USB cables (the 1 it came with and 2 amazon basics ones)
    • connected to a USB port on a USB 3.0 PCIe card
    after all of that I gave up for a few times and came back to try some new stuff:

    • Formatted my HDD and reinstalled win10 pro
    • purchased a PCI-e USB3.1 card

    What works:

    • Ripsaw always has a steady green light
    • Setting my console to 480p
      • As soon as I go to 720p or 1080p it will bug out like in that video and/or just straight freeze immediately.

    Everything works fine on my Asus Laptop and other Desktop.

    PC Specs:
    • Windows 10 Pro
    • Intel i7-5820K
    • 16GB DDR4 Ram
    • Nvidia GeForce GTX960
    any help would be appreciated
     
    Last edited: Jan 7, 2019
    Kyracf likes this.
  2. Kyracf

    Kyracf New Member

    I have the same issue. I have been using the Razer Ripsaw pretty well for more than 1 year. I put it back in use today and it wasn't working. When I activate the capture card on OBS, the video stutters for a few seconds and then frezees, while the audio pops and makes noises. I have tried reinstalling both Synpase, OBS and Xsplit but it didn't help. I have tried to use the Ripsaw on another computer and it's working there, so I'm assuming it's some kind of driver issue.
    My Specs:

    Windows 10 Home
    Intel i7-4710HQ
    16 GB RAM
    Nvidia Geforce GTX 980M
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >