Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer Ripsaw HD capturing Samsung Galaxy S10 in OBS

Discussion in 'Razer Support' started by Deertechx790, Jul 19, 2019.

Thread Status:
Not open for further replies.
  1. Deertechx790

    Deertechx790 New Member

    I recently purchased a Razer Ripsaw HD and I want to stream some games from a Samsung Galaxy S10. I managed to connect the phone to the card via OTG and I get video and sound from the phone in OBS.

    However, the resolution that the Ripsaw outputs is at 720p 60 FPS (A notification pops up on Windows to inform about the output) but it is not re-scaling to fit the screen from Android in OBS. It seems as if the recording is zoomed in at the upper left side of the screen on horizontal orientation and zoomed in at the upper part of the screen on vertical orientation.

    I tried to change output resolution in OBS and match the 1280x720 coming from the card but that didn't fix the issue. Tried also to fit/ stretch to screen from OBS option to no avail.

    How can I fix this issue? Why Ripsaw outputs only 1280x720 when android screen is in higher resolution (2280x1080)? And why the screen doesn't re-scale to fit the output dimensions?

    FYI, I connected the phone to a TV using only HDMI (the exact one provided with Ripsaw) and the whole screen is mirrored normally both horizontally and vertically.
     
  2. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hello there! Can you share a video of the issue? Please include your current setup as well.
     
  3. Deertechx790

    Deertechx790 New Member

    More updates regarding the issue. It seems that if I plug the card and I open OBS really quick then for a few seconds the whole phone screen appears. But then it seems that something kicks in, the card automatically changes resolution to 720p and OBS capture freezes. Then if I restart OBS the resolution is destroyed again.

    I have tried this with all resolutions in my phone and the result is always the same.

    So 3 videos. The first one is what I described above. Few seconds of capturing full screen, then resolution changes by the card and everything freezes:


    The next two is the outcome of the changed resolution. Both vertically and horizontally only part of the screen is captured.




    In the link below I have attached photos of my setup as well.

    https://drive.google.com/open?id=1lmuuiDvWAFXLbedAV4AInEHQgkiJpm2V

    I connect the card with the USB on my laptop (on a USB 3.1 port), then I connect the card (IN port) with the HDMI cable with a USB-C to HDMI adapter and I plug my phone with the adapter. Notice that I don't connect additional HDMI to the pass-through but I believe this shouldn't be a reason for the card not to work.
     
    Last edited: Jul 24, 2019
  4. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Thanks for the videos. Can you PM me the serial number of your Ripsaw HD? Let's continue there.
     
  5. SarChus

    SarChus New Member

    Any solutions for this issue? I have the same problem with topic creator. Please share if you can solved this problems.

    Thanks,
     
  6. Deertechx790

    Deertechx790 New Member

    Hi. Well a case was opened but their quoted answer was:
    "the Ripsaw HD was designed for PC or console and since you are using it on a phone with a third party adapter and the issue is only present there, we can not replace the unit"

    So for them the issue seemed to be treated like a faulty device, but to me it is more of a compatibility issue (I tested the Ripsaw capturing a PC and worked OK).

    I would advise you to sell the Ripsaw and buy an ElGato HD60S and I am planning to do the same as well. I regret not doing my research correctly before I made the purchase. ElGato's software is compatible with Android and iOS and there are a lot of videos how to capture your phone with it while there is zero info for that for the Ripsaw HD.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >