Razer Sila - App Can't Connect Needs 1.2.170 Or Above

Discussion in 'Razer Support' started by IM35461, Feb 12, 2019.

Thread Status:
Not open for further replies.
  1. IM35461

    IM35461 New Member

    My internet connection needs account details so I set it up via the web browser but now trying to use the Android app it says this when you try and pair it.

    Screenshot_2019-02-12-12-20-34-278.jpg

    I assumed clicking okay would make it perform an update but it does not and it just takes you back to the pairing wizard again.

    In the web interface there does not seem to be an option to trigger a manual firmware update or check which also seems very strange.

    Box says it is on RazerSila-2.0.411_api-2.0.384


    Not very impressed with the security of default router password.
     
  2. IM35461

    IM35461 New Member

    An update on that, looking at the firmware version on the box which looks like it is higher than 1.2.170 I thought it would be worth trying the app on another Android device (on V8.x) and that worked first time :)

    Screenshot_20190212-130254.png

    The Tablet it did not work on has these details.
    Screenshot_2019-02-12-13-12-53-359.jpg

    So no longer a major problem and the app says my box is on the current firmware.
     
  3. Rox598

    Rox598 Keyblade Master VANGUARD

    Glad you got sorted OP!

    How are you finding the sila otherwise?
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >