Razer Stealth 2018 turns off even when plugged in with heavy GPU load

Discussion in 'Razer Support' started by treat.adam, Jan 5, 2019.

Thread Status:
Not open for further replies.
  1. treat.adam

    treat.adam New Member

    Hi,

    Just received my new Razer Stealth 2018 4k edition with NVIDIA Geforce MX150 and 65w charger. It is beautiful machine, but the laptop loses charge and turns off even when plugged in if I run the GPU under heavy compute loads using CudaNN.

    This is running Ubuntu 18.04 with nvidia-driver-410 and cudann 7.4

    I'm thinking the Nvidia Powermizer is not kicking in? Is there something in the bios I need to change?

    Any support would be appreciated.
     
  2. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Hey @treat.adam, have you reached out to our Systems Team about this? I'm not well versed in Linux troubleshooting but do send me a PM so we can try to isolate.
     
  3. arthur.sdg

    arthur.sdg New Member

    @Razer.Caziel

    I'm going through the same problem.

    when playing CS:GO, even when the computer is plugged in, the battery runs out and turns off the computer.

    I'm using windows 10

    The New Razer Blade Stealth - 4K Touch - 16GB RAM - 512GB SSD
     
  4. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Oh, snap! Send me a PM and I'll try to get you back in the game before Astralis wins another tournament.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >