Razer Synapse 3 fails to install

Discussion in 'Razer Support' started by EligibleSRB, Dec 19, 2021.

Thread Status:
Not open for further replies.
  1. EligibleSRB

    EligibleSRB New Member

    Hello everyone :)

    I have a problem with installing Razer Synapse 3 on mine PC. I've downloaded installation file from Razer's site and when I try to run it (even as Admin) it says "Server Access Unavailable - Please check your internet connection" (screenshot attached).

    This is happening only on mine desktop PC which I've got a few days ago (Ryzen 7 5800X, RTX 3070, 16GB Corsair Vengeance RGB Pro, Gigabyte X570 Gaming X), LAN connection ofc, Windows 10 Pro (legal, all is up to date). Devices I own are Naga Pro and BlackWidow v3 Mini Hyperspeed.

    I've tried this installation on the 3 other laptops (via wifi) - no issues there whatsoever.

    I've tried everything - from reinstalling Windows (2 times and even with other non-Razer hardware), disabling firewall, deleting my Razer devices from Device manager, flushing DNS, checking for latest .NET version - basically everything I've found on reddit and other forums.

    I've contacted support (chat which forwarded me to some senior-like support via email) and everything they've told me I already did. I did try it again ofc, but no success.

    I'll try to go tomorrow to get wifi adapter and to try installation via that connection, but its kinda overkill that i've paid almost 450$ for the Razer hardware and now I need to spend extra just to be able to get hands on their software on 2500$ desktop rig.

    Any suggestion or help is really appreciated :)
     

    Attached Files:

  2. Sye_The-Vie

    Sye_The-Vie Well-Known Member VANGUARD

    Have you tried updating the Windows with the Windows update?
    I once tried to install Synapse 3.0 on Windows 10 Version 1607, it produced the same error.

    By updating to above Ver 1909, it installed without any issues
     
  3. EligibleSRB

    EligibleSRB New Member

    Hi, tnx for reply. Unfortunately yes, everything on PC is up to date (Windows included)
     
  4. Sye_The-Vie

    Sye_The-Vie Well-Known Member VANGUARD

    Not sure if this will work, try updating your CPU firmware
     
  5. EligibleSRB

    EligibleSRB New Member

Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >